Меню
Разработки
Разработки  /  Информатика  /  Презентации  /  10 класс  /  Решение задач на массивы

Решение задач на массивы

В презентации рассматриваются задачи на использование двумерных и одномерных массивов.
13.10.2014

Описание разработки

1. Заполнение массива вручную:

For i:=1 to N do

BEGIN

write (‘A[‘, i, ‘]=‘); readln (A[i]);

END;

A[1]=2

A[2]=5

A[N]=…

2. Заполнение одномерного массива случайными числами:

Randomize;

For i:=1 to N do

BEGIN

A[i]:= random(k);  {k - число}

write (A[i],’  ‘);

END;

презентация по информатике решение задач на массивы

3. Заполнение двумерного массива случайными числами:

Randomize;

For i:=1 to N do {i – номер строки}

BEGIN

For j:=1 to N do {j – номер столбца}

BEGIN

A[i,j]:= random(k); {k - число}

write (A[i,j],’  ‘);

END;

writeln; {переход на новую строку для заполнения}

END.

Содержимое разработки

Урок информатики и ИКТ в 10 классе  Тема урока: «Решение задач на массивы»

Урок информатики и ИКТ в 10 классе Тема урока: «Решение задач на массивы»

1. Заполнение массива вручную : For i:=1 to N do BEGIN  write (‘A[‘, i, ‘]=‘); readln (A[i]); END; A[1]=2 A[2]=5 … A[N]=…

1. Заполнение массива вручную :

For i:=1 to N do

BEGIN

write (‘A[‘, i, ‘]=‘); readln (A[i]);

END;

A[1]=2

A[2]=5

A[N]=…

2 . Заполнение одномерного массива случайными числами : Randomize; For i:=1 to N do BEGIN  A[i]:= random(k);   {k - число }  write (A[i],’ ‘); END; 7 12 8 45 …

2 . Заполнение одномерного массива случайными числами :

Randomize;

For i:=1 to N do

BEGIN

A[i]:= random(k); {k - число }

write (A[i],’ ‘);

END;

7 12 8 45 …

3 . Заполнение двумерного массива случайными числами : Randomize; For i:=1 to N do  {i – номер строки } BEGIN   For j:=1 to N do  {j – номер столбца }    BEGIN   A[i,j]:= random(k);   {k - число }   write (A[i,j],’ ‘);   END;  writeln;   { переход на новую строку для заполнения } END;

3 . Заполнение двумерного массива случайными числами :

Randomize;

For i:=1 to N do {i – номер строки }

BEGIN

For j:=1 to N do {j – номер столбца }

BEGIN

A[i,j]:= random(k); {k - число }

write (A[i,j],’ ‘);

END;

writeln; { переход на новую строку для заполнения }

END;

Вывести на экран сумму четных элементов одномерного массива из 10 чисел (случайные числа) Подсказка For i:=1 to 10 do  If A[i] mod 2=0 then S:=S+A[i];

Вывести на экран сумму четных элементов одномерного массива из 10 чисел (случайные числа)

Подсказка

For i:=1 to 10 do

If A[i] mod 2=0 then S:=S+A[i];

Задача 2   Вывести на экран все отрицательные числа одномерного массива из 20 чисел и произведение этих чисел ( A[i]:=random(50)-25). Подсказка P:=1; For i:=1 to 2 0 do Begin  If A[i]  Begin    wrate(A[i],’ ‘); P:=P*A[i];  End; End;

Задача 2

Вывести на экран все отрицательные числа одномерного массива из 20 чисел и произведение этих чисел ( A[i]:=random(50)-25).

Подсказка

P:=1;

For i:=1 to 2 0 do

Begin

If A[i]

Begin

wrate(A[i],’ ‘); P:=P*A[i];

End;

End;

Задача 3   Все отрицательные элементы одномерного массива из 20 элементов заменить на число 10 ( A[i]:=random(50)-25).  Подсказка For i:=1 to 10 do Begin  If A[i]  Write (A[i],’ ‘); End;

Задача 3

Все отрицательные элементы одномерного массива из 20 элементов заменить на число 10 ( A[i]:=random(50)-25).

Подсказка

For i:=1 to 10 do

Begin

If A[i]

Write (A[i],’ ‘);

End;

Задача 4 Определите, на сколько сантиметров отличается рост самого высокого и самого низкого учащихся в классе.

Задача 4

Определите, на сколько сантиметров отличается рост самого высокого и самого низкого учащихся в классе.

max then max:=A[i]; If A[i] End; Raz:=max-min; Writeln(‘max=’, max, ‘ min=‘, min, ‘ raz:=‘, raz); " width="640"

max:=A[1]; min:=A[1];

For i:=2 to N do

Begin

If A[i]max then max:=A[i];

If A[i]

End;

Raz:=max-min;

Writeln(‘max=’, max, ‘ min=‘, min, ‘ raz:=‘, raz);

Задача 5   Составьте программу вычисления суммы элементов в каждом столбце матрицы С размера NxN.

Задача 5

Составьте программу вычисления суммы элементов в каждом столбце матрицы С размера NxN.

Подсказка Перебор начинаем со столбца j, а заполняем массив С [i,j]. For j:=1 to N do Begin  For i:=1 to N do  S:=S+C[i,j];  write(‘S(‘ , j,’)=‘,s,’ ‘);  S:=0;   {s – обнуляем, считаем сумму 2     столбца } End;

Подсказка

Перебор начинаем со столбца j, а заполняем массив С [i,j].

For j:=1 to N do

Begin

For i:=1 to N do

S:=S+C[i,j];

write(‘S(‘ , j,’)=‘,s,’ ‘);

S:=0; {s – обнуляем, считаем сумму 2 столбца }

End;

Задачи Присвойте значение 5 всем элементам массива D , имеющим номер кратный 3. Дан одномерный массив. Найдите сумму элементов массива с четными индексами. Составьте программу вычисления произведения отрицательных элементов матрицы. Составьте программу вычисления суммы элементов во второй строке матрицы С

Задачи

  • Присвойте значение 5 всем элементам массива D , имеющим номер кратный 3.
  • Дан одномерный массив. Найдите сумму элементов массива с четными индексами.
  • Составьте программу вычисления произведения отрицательных элементов матрицы.
  • Составьте программу вычисления суммы элементов во второй строке матрицы С
-80%
Курсы дополнительного образования

Основы HTML

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Сохранить у себя:
Решение задач на массивы (0.21 MB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт