10/19/17
Условный оператор
Разветвляющийся алгоритм – это алгоритм, в котором в зависимости от условия выполняется либо одна, либо другая последовательность действий.
Основные варианты структуры ветвления:
если - то; если – то - иначе;
Полная форма
Неполная форма
да
нет
нет
условие
да
условие
серия команд 1
серия команд 2
серия команд 1
If then else
If then
IF THEN
BEGIN
;
;
…
;
END
ELSE
BEGIN
;
;
…
;
END;
Если по условию задачи после THEN или ELSE необходимо выполнить больше одного оператора, то тогда используют операторные скобки BEGIN…END
Сложные условия
В сложных условиях используются логические выражения, записанные с помощью логических операций.
Мультипликативные
операции:
Div - целая часть от деления
Mod - остаток от деления
Логические операции:
Not - Не
And - И
Or - Или
Каждое простое условие заключается в скобки
Исправить ошибки программы на компьютере и вывести на экран вместе с ответом слово «молодец».
Program z1
Var N – integer
Begin write( введи число )
read ( N)
N =2*N
write (‘N=’, N)
End.
20 then y:=x*x else y:=x/2; write (y); end. " width="640"
Что получится в результате выполнения программы, если было введено число 2 ?
program T;
Var y,x: integer;
begin
read (x);
x:=x+10;
if x20 then y:=x*x
else y:=x/2;
write (y);
end.
Запишите программу, используя условный оператор, которая вычисляет значение функции:
Задача № 1 : Определить является ли введенный с клавиатуры год високосным.
Задача № 2 : ЭВМ спрашивает: «Сколько вам лет?». Если ответ больше 50, то отвечает: «Вы хорошо сохранились!». В противном случае желает: «Лет до 100 расти вам без старости!».
Задача № 3 : Даны два действительных числа. Возвести сумму этих чисел в квадрат, если первое число больше второго и возвести разность этих чисел в квадрат в противном случае.
Задача № 4 : Написать программу, проверяющую, принадлежит ли введенное с клавиатуры число интервалу (0;5].
Задача 1.
Из двух введеных с клавиатуры чисел с разной четностью вывести на экран нечетное число
Задача 2.
Определить количество дней в году, который вводит пользователь.
Задача 3.
Определить какое из трех, введенных пользователем, чисел максимальное и вывести его на экран.
0 THEN BEGIN x1:=(-b+SQRT(D))/(2*a); x1:=(-b-SQRT(D))/(2*a); WRITELN (‘x1= ‘,x1:5:2,’x2= ‘,x2:5:2); END ELSE IF D=0 THEN BEGIN x:= -b/(2*a); WRITELN (‘x= ‘,x:5:2); END ELSE WRITELN (‘Корней нет’); END. Внешнее условие Вложенное условие " width="640"
Программа для решения квадратного уравнения
PROGRAM zadacha2;
VAR a,b,c,D,x,x1,x2:REAL;
BEGIN
WRITE(‘a=’); READLN(a);
WRITE(‘b=’); READLN(b);
WRITE(‘c=’); READLN(c);
D:= b*b - 4*a*c;
WRITE (‘Корни уравнения: ‘);
IF D0 THEN
BEGIN
x1:=(-b+SQRT(D))/(2*a);
x1:=(-b-SQRT(D))/(2*a);
WRITELN (‘x1= ‘,x1:5:2,’x2= ‘,x2:5:2);
END
ELSE
IF D=0 THEN
BEGIN
x:= -b/(2*a);
WRITELN (‘x= ‘,x:5:2);
END
ELSE
WRITELN (‘Корней нет’);
END.
Внешнее условие
Вложенное условие

Условный оператор в языке программирования Pascal (340.14 KB)

