Меню
Разработки
Разработки  /  Информатика  /  Тесты  /  8 класс  /  Тестирование по теме "Программирование в среде Pascal"

Тестирование по теме "Программирование в среде Pascal"

Тестирование по теме "Программирование в среде Pascal"

11.10.2016

Содержимое разработки

Контрольный тест "Язык программирования Паскаль"

Выполнил: ___________________________________________________________________________________

(фамилия, имя, класс)

  1. Разработчиком языка Паскаль является:

    а) Блез Паскаль

    б)Никлаус Вирт

    в) Норберт Винер

    г) Эдсгер В.Дейкстра


  2. Установите соответствия между типами данных и типами переменных в Паскале

  3. В данном фрагменте программы:
    program error;
    begin
    SuMmA:=25-14;
    end.

    ошибкой является:

а) некорректное имя программы

б)не определено имя переменной

в) некорректное имя переменной

г) запись арифметического выражения


  1. Что из ниже перечисленного не входит в алфавит языка Паскаль?

а) латинские строчные и прописные буквы

б) служебные слова

в) русские строчные и прописные буквы

г) знак подчеркивания


  1. Какая клавиша нажимается после набора последнего данного в операторе read?

    а) Enter


    б) точка с запятой

    в) пробел

    г) Ctrl

  2. Разделителями между операторами служит:

    а) точка


    б) точка с запятой

    в) пробел

    г) запятая

  3. В программе на языке Паскаль обязательно должен быть:

    а) заголовок программы


    б) блок описания используемых данных

    в) программный блок

    г) оператор присваивания

  4. При присваивании изменяется:

    а) имя переменной


    б) тип переменной


    в) значение переменной

    г) значение константы

  5. Вещественные числа имеют тип данных:

    а) real

    б) integer

    в) boolean

    г) string

  6. Описать переменную – это значит указать её:

    а) имя и значение

    б) имя и тип

    в) тип и значение

    г) имя, тип и значение

  7. Для генерации случайного целого числа из промежутка [10; 20) необходимо использовать выражение:

    а) random*20

    б) random (20)

    в) random(10)+10

    г) random(10)*2

  8. Какие последовательности символов могут служить именем в языке Паскаль?

    а) _mas

    б) 2x

    в) x2

    г) MaS1

  9. Для вывода результатов в Паскале используется оператор:

    а) begin

    б) readln

    в) write

    г) print

  10. Какого раздела не существует в программе, написанной на языке Паскаль?

    а) заголовка

    б) примечаний

    в) описаний

    г) операторов

  11. Найдите ошибки в записи программы, исправьте их.

programпроизведение

A, B, C: real

begin

readln (A, B)

C = A * B

writeln (Произведение введенных Вами чисел равно , C)

end.

  1. Укажите недопустимые имена программ на Паскале:

    а) 666

    б) readln

    в) сумма

    г) chisla

  2. Запишите на Паскале следующее арифметическое выражение:

  1. В алгоритме, записанном ниже, используются целочисленные переменные a и b. Определите значение переменной b после выполнения данного алгоритма:

a := 7;

b := a – 8;

a := -3 * b + 3;

b := a / 2 * b

  1. Напишите программу для вычисления периметра и площади прямоугольного треугольника по заданным длинам двух катетов a и b.

-80%
Курсы дополнительного образования

Создание динамических веб-страниц с помощью PHP и MySQL

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Тестирование по теме "Программирование в среде Pascal" (28.26 KB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт