Вопросы:
Вопрос №: 1
Определите значения переменных после выполнения серии операторов…
x:=2;
y:=x*2;
y:=y - 5*x;
x:=abs(y);
write(‘x=’, x, ’ y=’, y);
Варианты ответов:
- x=6 y= - 6
- x=2 y= - 2
- x=4 y= - 4
- x=2 y= - 8
Вопрос №: 2
В результате выполнения фрагмента программы:
k:=1;
f:=1;
while k<6 do
begin
f:=f*k;
k:=k+2
end;
write(‘f=’, f, ’ k=’, k);
на экран будет выведена следующая пара чисел…
Варианты ответов:
- f=15 k=5
- f=15 k=7
- f=13 k=7
- f=13 k=5
Вопрос №: 3
Чтобы определить количество положительных элементов в массиве A[1. . N],
в условном операторе фрагмента программы:
k:=0;
for i:=1 to N do
if _________ then k:=k+1;
нужно использовать логическое выражение…
Варианты ответов:
- A[i]<0
- A[i]>N
- i>0
- A[i]>0
Вопрос №: 4
Определите значения переменных после выполнения серии операторов…
j:= - 2;
s:=0;
while j<2 do
begin
j:=j+1;
if j=0 then a:=1 else a:=1/j;
s:=s+a
end;
write(‘j=’, j, ’ s=’, s);
Варианты ответов:
- j=1 s=1
- j=2 s=0. 5
- j=2 s=1. 5
- j=2 s=1
Вопрос №: 5
Какое логическое выражение нужно вписать во фрагмент программы,
определяющий индекс первого элемента массива P[1. . N], не равного x?
m:=0;
for i:=1 to N do
if _________ then m:=i;
Варианты ответов:
- P[i]<>x
- P[i]=x
- P[i]>x
- i<=x
Вопрос №: 6
Дана программа на языке Паскаль:
program abx;
var n, i, s:integer;
begin
n:=15;
s:=0;
for i:=7 to n do
if i mod 7 =0
then s:=s+i;
writeln(s)
end.
В результате выполнения этой программы будет выведено…
Варианты ответов:
- 7
- 21
- 2
- 14
Вопрос №: 7
Дана программа на языке Паскаль:
program abx;
var x:integer;
begin
readln(x);
if x mod 2 =0
then writeln(‘да’)
else writeln(‘нет’);
end.
При каком значении x (из представленных ниже) будет получен ответ «да»?
Варианты ответов:
- 7
- 3
- 15
- 4
Вопрос №: 8
Чему будет равно k после исполнения фрагмента программы:
k:=1;
while (a[k]<>x) and (k<=10) do
k:=k+1;
если в качестве элементов массива будут введены числа 2, 3, 5, 7, 9, 12, 0, 7, 6, 7, а x=7?
Варианты ответов:
- 11
- 1
- 4
- 10
Вопрос №: 9
Определите значения переменных после выполнения серии операторов…
a:=42;
b:=14;
a:=a div b;
b:=a*b;
a:=b div a;
write(‘a=’, a, ’ b=’, b);
Варианты ответов:
- a=14 b=42
- a=1 b=42
- a=0 b=588
- a=42 b=14
Вопрос №: 10
Определите значения переменных после выполнения серии операторов…
x:=1. 2;
y:=x*2;
y:=y - 5*x;
x:=abs(y);
write(‘x=’, x, ’ y=’, y);
Варианты ответов:
- x=3. 6 y= - 1. 2
- x=1. 2 y= - 1. 2
- x=3. 6 y= - 3. 6
- x=1. 2 y= - 3, 6
Вопрос №: 11
Какое значение примет переменная k в результате выполнения приведенной ниже программы?
Program a1;
var i, k:integer;
begin
k:=0;
for i:=1 to 100 do
if i mod 2 =0 then k:=k+1;
writeln(‘k=’, k)
end.
Варианты ответов:
- k=100
- k=2
- k=10
- k=50
Вопрос №: 12
В результате выполнения фрагмента программы:
s:=0; i:=3;
while i>1 do
begin
y:=1; j:=1
while j<3 do
begin
y:=y*i; j:=j+1
end;
s:=s+y; i:=i - 1
end;
write(‘s=’, s, ’ y=’, y);
на экран будет выведена следующая пара чисел…
Варианты ответов:
- s=10 y=9
- s=13 y=4
- s=8 y=7
- s=6 y=5
Весь материал, включая ответы, - смотрите документ.

Тест по информатике по теме "Язык программирования Паскаль" (79.5 КB)

