Цели урока:
- Закрепить информацию об операциях над строковыми величинами.
- Добиться усвоения знаний учащимися на уровне воспроизведения.
- Научить производить сортировку списка.
- Развитие логического, алгоритмического мышления, познавательного интереса.
- Воспитание аккуратности, дисциплинированности, самостоятельности.
Оборудование: видеопроектор, персональные компьютеры.
Программное обеспечение:
TurboPascal, Microsoft PowerPoint (презентация), Microsoft Word.

GERTEIN, ВОЛМИС, КСТТЕ, ТИРОВСОРКА (integer, символ, текст, сортировка)
3. Повторение пройденного (слайды 12-26)
- Какая величина называется литерной?
(Величина значением которой является текст)
- Какая величина называется символьной?
(Величина значением которой является символ)
- Как описывается переменная символьного типа? (char)
- Какая величина называется строковой?
(Величина значением которой является текст)
- Какова максимальная длина строковой величины? (255)
a:=’Маша ела кашу’
Чему равны: а[1], a[3], a[5], a[0]?
- Как описывается переменная строкового типа? (string)
- Какая функция определяет длину строковой величины? (length)
a:=lengt(‘школа’); Чему равно а? (5)
- Какая функция удаляет из строковой величины подстроку? (delete)
Каков результат выполнения программы
var a: string;
begin
a:=‘значение’;
delete(a,4,2);
writeln(a);
end. (знание)
- Какая функция вырезает из строковой величины подстроку?
Каков результат выполнения программы
var a: string;
begin
a:=‘ информатика’;
writeln(copy(a,3,5));
end. (форма)
- Какая процедура вставляет подстроку в строку?
Каков результат выполнения программы
var a: string;
begin
a:=‘око’;
insert(‘мол’,a,1);
writeln(a);
end. (молоко)
Определите результат выполнения программ: - смотри документ
4. Использование программ в Microsoft Word (демонстрация)
- Сервис статистика →…
- Строка состояния
- Сервис → параметры → правописание → настройка →…
- Кнопки сортировки (упорядочивание таблицы «предметы»)
5. Теоретическое выполнение заданий.
1) Сравнение величин
а) кодирование символов; (слайд 28)
б) сравнение величин: a и б, аа и а, аа и аа, Аа и аа (слайд 29)
2) Составить программу упорядочивания списка по алфавиту. (слайд 30)
(переделать программу «Сортировка массива»)
var t:array[1..100] of string;
n,i,j:integer; c:string;
begin
write('n=');readln(n);
for i:=1 to n do
begin
write(i,'. '); readln(t[i])
end;
for j:=1 to n-1 do
for i:=1 to n-j do
begin
if t[i]>t[i+1] then
begin c:=t[i];t[i]:=t[i+1];t[i+1]:=c; end;
end;
writeln;
for i:=1 to n do writeln(i,'. ',t[i]);
readln
end.
6. Практическое выполнение задания.
Набор программы на компьютере.
7. Задание на дом: №15, стр.91
8. Итоги урока.
Подведение итогов. Выставление оценок.

Строковые величины в Pascal (2.07 MB)

