Меню
Разработки
Разработки  /  Информатика  /  Уроки  /  Символы и строки в Pascal ABC

Символы и строки в Pascal ABC

Серия разработок уроков по программированию в программе pascal ABC.
18.11.2012

Описание разработки

Серия разработок уроков по программированию в программе pascal ABC.

Цели:

  познакомить учащихся с типом данных ‘string’;

формировать практические навыки учащихся составлять программы, используя строковые величины;

развивать воображение, логическое мышление;

  ответственность за сохранность школьного имущества, в частности, компьютерного класса;

ответственность и требовательность к себе.

Ход урока:

1.      Организационный момент

2.      Изучение нового материала:

Для хранения строк текста в языке Pascal используются переменные типа string. Одна переменная этого типа может хранить строку длиной до 255 символов. Значениями типа string могут быть строки любых символов, заключенные в одинарные кавычки, например: ‘школа’, ’уроки информатики’. Если кавычка должна входить в состав строки, то ее следует повторить дважды, например: ‘на Pascal’е’. К каждому символу строки можно обратиться как к элементу таблицы. Кроме того, к строкам применима операция «+», которая позволяет склеивать две строки в одну.

Например, пусть дана строковая величина s. Пусть значением этой величины будет слово «абракадабра». Тогда можно говорить, что первый элемент строковой величины – а, второй – б, третий – р. Записывают это следующим образом - s[1]=а; s[2]=б; s[3]=р и т.д.

Строки можно сравнивать между собой. Сравнение строк происходит по следующему правилу. Сначала сравниваются коды первых символов строк, какой код больше, та и строка больше. Если коды первых символов равны, то сравниваются коды вторых символов. У какого из вторых символов код больше, та и строка больше. Если и коды вторых символов равны, то сравниваются коды третьих символов и т.д.  если при сравнении одна из строк закончилась, то большей строкой считается более длинная. Например: ‘ABC’ < ‘BBC’; ‘стол ‘ >’стул ‘ и т.д.

Длину строки можно узнать с помощью функции length.

1. Составить программу, которая запрашивает имя человека и повторяет его на экране.

program z1;

var imja: string;

begin

writeln ('Введите ваше имя');

readln (imja);

writeln (imja);

end.

                        2. Дано название города. Определить, четно или нет количество символов в нем.

program s2;

var gorod: string; a, k: integer;

begin

writeln('Введите название города');

read(gorod);

a:=length(gorod);

k:=a mod 2;

if k=0 then writeln('четное')else writeln('нечетное')

end.

                        3. Дано слово. Вывести на экран его третий символ и дважды его последний символ.

                                   program s3;

var a: string; b, i: integer;

begin

writeln('Введите слово');

read(a);

b:=length(a);

if b>=3 then begin writeln(a[3]);

writeln(a[1]);

writeln(a[1]);

end;

end.

4. Дано слово. Определить, одинаковы ли второй и четвертый символы в нем.

program s4;

var a: string; c, d: char; b, i: integer;

begin

writeln('Введите слово');

read(a);

if ord (a[2])= ord(a[4])then writeln('равны') else writeln('неравны');

end.

3.   Рефлексия

4.      Домашнее задание:

1.      Составить программу, которая запрашивает название футбольной команды и повторяет его на экране со словами: «Это чемпион».

2.      Даны названия трех городов. Вывести на экран самое длинное и самое короткое название.

3.      Дано слово. Вывести на экран его  к-ый символ.

-80%
Курсы дополнительного образования

Основы HTML

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Сохранить у себя:
Символы и строки в Pascal ABC (0.66 MB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт