Меню
Разработки
Разработки  /  Информатика  /  Уроки  /  9 класс  /  Разработка урока по информатике по теме "Программирование алгоритмов ветвления"

Разработка урока по информатике по теме "Программирование алгоритмов ветвления"

Разработка расскажет и научит применять в программировании алгоритмы ветвления.
14.12.2014

Описание разработки

Цель урока

Приобретение обучающимися опыта программирования алгоритмов ветвления для дальнейшего применения полученных умений при изучении блока «Программирование»

Задачи урока

1. Повторить понятия алгоритма, алгоритма ветвления и этапы построения алгоритмов ветвления.

2. Провести сравнительный анализ графической записи алгоритма ветвления и программы алгоритма ветвления.

3. Отработать навыки программирования алгоритмов ветвления.

Разработка урока по информатике по теме Программирование алгоритмов ветвления

5. Выполните задание

6. У меня вот что получилось, а у вас?

Произведем анализ задачи:

Полную информацию смотрите в файле. 

Содержимое разработки

Технологическая карта урока


Предмет, класс

Информатика и ИКТ, 9 класс

Учитель

Зенцова Елена Николаевна

Тема урока,

№ урока по теме

«Программирование алгоритмов ветвления»

(раздел «Алгоритмы и исполнители»)

18

Цель урока

Приобретение обучающимися опыта программирования алгоритмов ветвления для дальнейшего применения полученных умений при изучении блока «Программирование»

Задачи урока

  1. Повторить понятия алгоритма, алгоритма ветвления и этапы построения алгоритмов ветвления.

  2. Провести сравнительный анализ графической записи алгоритма ветвления и программы алгоритма ветвления.

  3. Отработать навыки программирования алгоритмов ветвления.

 

Тип урока

Открытие нового знания

Актуальность использования средств ИКТ


Необходимое аппаратное и программное обеспечение

Средства мультимедиа, ПК для учеников, среда программирования PascalABC.

Образовательные ресурсы Интернет

pascalabc.net


Дидактическая структура урока

Деятельность учителя

Деятельность учеников

Задания для учащихся, выполнение которых приведет к достижению планируемых результатов

Планируемые результаты

Предметные




УУД





Обучающиеся смогут:

Организационный момент

 Подготавливает задание на доске. Раздает таблицы.

 Включают ПК

 

 

 

Проверка домашнего задания

1. В чём заключается задание на доске?



Необходимо составить алгоритм 




 №1.

Составьте алгоритм для решения задачи:

, при x=abc


 давать определение понятию алгоритм;





 


2. А что такое алгоритм?

Алгоритм – определённая последовательность действий для решения задачи.




3. А какого типа алгоритм мы получим?


Ветвления




4. Что такое алгоритм ветвления


Алгоритм ветвления – алгоритм, в котором выбор действия зависит от выполнения условия.


 давать определение понятию алгоритм ветвления;



Запишите в тетради число.

Запишите «Тема:» и оставьте место. Вы мне её скажите сами позже.

Производят записи в тетради



5. Выполните задание


Выполняют задание в тетради.


составлять блок схему алгоритма ветвления;



6. У меня вот что получилось, а у вас?


Произведем анализ задачи:
Найти: z
Ввести: a,b,c
Вычислить: x




Проводят самоанализ решения задачи.



проводить самоконтроль при решении задач;


7. Выполните следующее задание


Пытаются выполнить задание

№2.

Составьте программу для решения задачи:

, при x=abc





8. Смогли выполнить?

Почему?


Нет

Мы такого ещё не проходили.





9. Что нового?

Умеем мы программировать алгоритмы ветвления?

Составить программу алгоритма ветвления.

Нет




Изучение нового материала

А я говорю, что можем.

Посмотрите на задачи №1 и №2. Пример одинаковый?

 Да


Да

 

 

 

Скажите по какому плану будем действовать, для построения программы?




Как выглядит структура линейного алгоритма?







Давайте поглядим на программу алгоритма ветвления и определим, что нового для нас там есть:

program zd1;

var a,b,c,x,z: real;

begin

readln(a,b,c);

x:=a*b*c;

if x

else z:= x – a;

writeln(‘z=’,z);

end.


Сравним наш алгоритм и программу.

  1. Провести анализ

  2. Составить алгоритм

  3. Записать алгоритм на языке программирования


  1. Название программы;

  2. описание переменных;

  3. ввод данных

  4. вычисления;

вывод данных;


научиться выделять этапы и структуру программы линейного алгоритма;

уметь систематизировать свои знания;

Анализ:

1.Что такое program zd1;?

Компьютер должен знать, что мы собираемся писать программу.


Название программы



проводить сравнительный анализ и выделять закономерности;


2. Что означает раздел var?

Зачем нужен этот раздел?


Описание переменных.

Для всех переменных данного раздела компьютер подготавливает место в памяти и присваивает ему имя переменной.



3. Что такое «begin» и «end.»?






Это наши

начало



и

конец





4. Посмотрите на readln(a,b,c,u); и writeln(x, y, z);

Что означают операторы?

Какие данные вводим и выводим?



Это операторы ввода и вывода.

Те, что стоят внутри параллелограммов.



5. Что означает x:=a*b*c;

Вычисление переменной х.



6. Посмотрите на блок

if x

else z:= x – a;

Скажите, в нашем алгоритме, чему это может соответствовать и что означать?


Что такое then?

Что такое else?




Соответствует ромбу.




Ветку Да.

Ветку Нет.



Смогли мы выполнить задание?


Да.





Скажите, чем мы сейчас занимались?

А какие алгоритмы мы программировали?

Так какая сегодня тема?




Совершенно верно. Запишите тему.

Программировали.


Алгоритмы ветвления


«Программирование алгоритмов ветвления»





Закрепление нового материала

 Выполните задание в парах:


Какая пара выполнила, можете приступать к вводу на ПК

 Выполняют задание в тетради

 №3.

Составьте программу для решения задачи:

 

№4.

Составьте программу для решения задачи:

 

приобрести навыки программирования алгоритма ветвления;

 

 проводить самоконтроль при решении задач;

 

Контроль

 Загрузите систему программирования PascalABC.

В текстовом редакторе среды программирования введите текст программы и проведите её трассировку.

Если программа пошла, поднимите руку – вы сделали всё правильно.

 Выполняют задание на ПК

Рефлексия

Поднимите руки те, кто сегодня себя почувствовал программистом.

Поднимите руки те, кто сегодня понял, что он может программировать.

Поднимите руки те, кто сегодня пришел на урок.

Какие мы молодцы – мы все тянем руки отвечать! Значит мы все с вами тянемся к знаниям.

 

 

 

анализировать свои мысли и эмоции.


-80%
Курсы дополнительного образования

Основы HTML

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Сохранить у себя:
Разработка урока по информатике по теме "Программирование алгоритмов ветвления" (38.03 КB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт