
Задание #1
Вопрос:
"Программа" на языке программирования -
Выберите один из 3 вариантов ответа:
1) Program
2) Programm
3) Programma
Задание #2
Вопрос:
Ввод данных в строку осуществляется с помощью команды:
Выберите один из 4 вариантов ответа:
1) Write
2) Writeln
3) Read
4) Readln
Задание #3
Вопрос:
Определите результат команды Writeln(9, '+', 8) после запуска программы.
Выберите один из 3 вариантов ответа:
1) 17
2) 9+8
3) 9 + 8
Задание #4
Вопрос:
Определите результат команды Writeln(9+8) после запуска программы.
Выберите один из 3 вариантов ответа:
1) 17
2) 9 + 8
3) 9+8
Задание #5
Вопрос:
Определите результат команды Writeln(9, ' + ', 8) после запуска программы.
Выберите один из 3 вариантов ответа:
1) 17
2) 9+8
3) 9 + 8
Задание #6
Вопрос:
Вывод данных в строку осуществляется с помощью команды:
Выберите один из 4 вариантов ответа:
1) Write
2) Writeln
3) Read
4) Readln
Задание #7
Вопрос:
Оператор присваивания записывается следующим образом
Выберите один из 3 вариантов ответа:
1) =
2) :=
3) :
Задание #8
Вопрос:
Переведите слово "Иначе" на английский язык.
Задание #9
Вопрос:
Соберите структуру полной формы оператора ветвления
Укажите порядок следования всех 3 вариантов ответа:
__ then
__ else
__ if
Задание #10
Вопрос:
Как записывается оператор цикла "пока"?
Задание #11
Вопрос:
Соберите структуру циклического оператора, содержащего более двух команд в теле цикла.
Укажите порядок следования всех 4 вариантов ответа:
__ begin
__ while
__ end
__ do
Задание #12
Вопрос:
Сколько раз проверяется условие в ветвлениях?
Задание #13
Вопрос:
Каким должно быть условие для выполнения тела цикла?
Укажите истинность или ложность вариантов ответа:
__ истинным
__ ложным
Задание #14
Вопрос:
Можно ли ответить на вопрос о том, какое количество раз проверяется условие в циклическом операторе?
Задание #15
Вопрос:
Запишите оператор выбора
Задание #16
Вопрос:
Определите значение переменной a после выполнения алгоритма:
а := 5
b := 2 + a
а := a*b
b := 2*a - b
В ответе укажите одно целое число - значение переменной b.
Задание #17
Вопрос:
Определите, что будет напечатано в результате работы следующей программы.
Var s,k: integer;
Begin
s := 8;
for k := 14 to 18 do
s := s+6;
writeln(s);
End.
Задание #18
Вопрос:
Определите, какоечисло будет напечатано в результате работы следующей программы.
Var k, m: integer;
Tok: array[1..10] of integer;
Begin
Tok[1] := 10; Tok[2] := 14;
Tok[3] := 15; Tok[4] := 4;
Tok[5] := 12; Tok[6] := 6;
Tok[7] := 3; Tok[8] := 5;
Tok[9] := 5; Tok[10] := 10;
m := 0;
For k := 1 to 10 Do
If Tok[k] > 6 Then
Begin
m := m + 2;
End;
Writeln(m);
End.
Задание #19
Вопрос:
У исполнителя Делитель две команды, которым присвоены номера:
1. раздели на 2
2. вычти 3
Первая из них уменьшает число на экране в 2 раза, вторая уменьшает его на 3. Исполнитель работает только с натуральными числами. Составьте алгоритм получения из числа 41 числа 4, содержащий не более 5 команд. В ответе запишите только номера команд.
(Например, 11122 - это алгоритм: раздели на 2, раздели на 2, раздели на 2, вычти 3, вычти 3, который преобразует число 88 в 5.)
Задание #20
Вопрос:
Определите значение переменной b после выполнения алгоритма:
а := 7
b := 4
а := 2*а + 3*b
b := a/2*b
В ответе укажите одно целое число - значение переменной b.
Ответы:
1) (1 б.) Верные ответы: 1;
2) (1 б.) Верные ответы: 4;
3) (1 б.) Верные ответы: 2;
4) (1 б.) Верные ответы: 1;
5) (1 б.) Верные ответы: 3;
6) (1 б.) Верные ответы: 2;
7) (1 б.) Верные ответы: 2;
8) (1 б.) Верный ответ: "else".
9) (1 б.) Верные ответы: 2; 3; 1;
10) (1 б.) Верный ответ: "while".
11) (1 б.) Верные ответы: 3; 1; 4; 2;
12) (1 б.): Верный ответ: 1.;
13) (1 б.) Верные ответы: Да; Нет;
14) (1 б.) Верный ответ: "нет".
15) (1 б.) Верный ответ: "case".
16) (1 б.): Верный ответ: 63.;
17) (1 б.): Верный ответ: 38.;
18) (1 б.): Верный ответ: 10.;
19) (1 б.): Верный ответ: 21211.;
20) (1 б.): Верный ответ: 52.

Тест по информатике "Программирование в среде PascalABC" (2.35 КB)