Меню
Разработки
Разработки  /  Информатика  /  Проверочные работы  /  9 класс  /  Работа с файлами в Turbo Pascal

Работа с файлами в Turbo Pascal

Файл содержит примеры программ и тексты задач для самостоятельного решения.
17.02.2013

Описание разработки

ПРИМЕР 1. Написать программу, которая вычисляет среднее арифметическое чисел, находящихся в файле.

program primer;

uses crt;

var f: text;      n: integer;    kol: integer;    sum: integer;      sa: real;

begin

sum:=0;

kol:=0;

assign(f,'D:DistrTP umbers.txt');    {Связать файловую переменную с конкретным файлом}

reset(f);                                                {Открыть файл для чтения}

while not EOF(f) do                            {End of file?}

begin

readln(f,n);

sum:=sum+n;

kol:=kol+1;

end;

close(f);                                                {Закрыть файл}

sa:=sum/kol;

writeln('прочитано чисел ',kol);

writeln('сумма чисел  ',sum);

writeln('среднее арифметическое  ',sa:9:2);

readln;

end.

ПРИМЕР 2. Напишите программу, которая дописывает в файл 5 введённых пользователем целых чисел.

var f:text;                                                          {текстовый файл}

n: integer;                                                          {число}

i: integer;                                                            {счётчик чисел}

begin

writeln('Введите 5 целых чисел');

assign(f,'d:distrTP umbers.txt');             {Связать файловую переменную с конкретным файлом}

Append(f);                                                  {Открыть файл в режиме добавления}

for i:=1 to 5 do

begin

write('->');

readln(n);

writeln(f,n);

end;

close(f);                                               {закрыть файл}

writeln('Введённые числа добавлены в файл');

readln;

end.

ПРИМЕР 3. Вывести на экран содержимое файла.

var f : text;                                                     {текстовый файл}

n:integer;                                                        {число}

begin

writeln('Содержимое файла ');

writeln('----------------');

Assign(f, 'd:distrTP umbers.txt');

Reset(f);                                              {Открыть файл для чтения}

while not EOF(f) do                            {Пока не достигнут конец файла}

begin

readln(f,n);                                     {прочитать число из файла}

writeln(n);                                       {вывести прочитанное число на экран}

end;

Close(f);                                               {закрыть файл}

writeln('---------------------');

readln;

end.

Самостоятельная работа:

  1. Создать файл, состоящий из 10 значений типа integer. прочитайте файл и вычислите сумму его элементов.
  2. Прочитайте файл и выведите только чётные элементы.
  3. Создайте файл с 10 целыми числами. Переписать компоненты файла в обратном порядке.
  4. Создайте файл Q, содержащий компоненты файла F, делящиеся на 5 и принадлежащие промежутку [C,D]
  5. Создать файл из 50 случайных цифр. Вывести элементы созданного файла на экран.

Содержимое разработки

ПРИМЕР 1. Написать программу, которая вычисляет среднее арифметическое чисел, находящихся в файле.

program primer;

uses crt;

var f: text; n: integer; kol: integer; sum: integer; sa: real;

begin

sum:=0;

kol:=0;

assign(f,'D:\Distr\TP\numbers.txt'); {Связать файловую переменную с конкретным файлом}

reset(f); {Открыть файл для чтения}

while not EOF(f) do {End of file?}

begin

readln(f,n);

sum:=sum+n;

kol:=kol+1;

end;

close(f); {Закрыть файл}

sa:=sum/kol;

writeln('прочитано чисел ',kol);

writeln('сумма чисел ',sum);

writeln('среднее арифметическое ',sa:9:2);

readln;

end.

ПРИМЕР 2. Напишите программу, которая дописывает в файл 5 введённых пользователем целых чисел.

var f:text; {текстовый файл}

n: integer; {число}

i: integer; {счётчик чисел}

begin

writeln('Введите 5 целых чисел');

assign(f,'d:\distr\TP\numbers.txt'); {Связать файловую переменную с конкретным файлом}

Append(f); {Открыть файл в режиме добавления}

for i:=1 to 5 do

begin

write('-');

readln(n);

writeln(f,n);

end;

close(f); {закрыть файл}

writeln('Введённые числа добавлены в файл');

readln;

end.

ПРИМЕР 3. Вывести на экран содержимое файла.

var f : text; {текстовый файл}

n:integer; {число}

begin

writeln('Содержимое файла ');

writeln('----------------');

Assign(f, 'd:\distr\TP\numbers.txt');

Reset(f); {Открыть файл для чтения}

while not EOF(f) do {Пока не достигнут конец файла}

begin

readln(f,n); {прочитать число из файла}

writeln(n); {вывести прочитанное число на экран}

end;

Close(f); {закрыть файл}

writeln('---------------------');

readln;

end.

Самостоятельная работа:

  1. Создать файл, состоящий из 10 значений типа integer. прочитайте файл и вычислите сумму его элементов.

  2. Прочитайте файл и выведите только чётные элементы.

  3. Создайте файл с 10 целыми числами. Переписать компоненты файла в обратном порядке.

  4. Создайте файл Q, содержащий компоненты файла F, делящиеся на 5 и принадлежащие промежутку [C,D]

  5. Создать файл из 50 случайных цифр. Вывести элементы созданного файла на экран.

-80%
Курсы дополнительного образования

Создание динамических веб-страниц с помощью PHP и MySQL

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Работа с файлами в Turbo Pascal (30.5 КB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт