Язык программирования ABC Pascal
Язык программирования
- Это формальная знаковая система (набор команд), которую понимает компьютер.
- Алфавит языка – множество символов, используемых в этом ЯП.
В начале 70-х годов XX века швейцарский учёный Никлаус Вирт разработал язык программирования, и дал ему название Паскаль, в честь знаменитого французского математика XVII века, изобретателя первой счётной машины Блеза Паскаля. С помощью ЯП Паскаль можно разрабатывать программы самого разного назначения. Синтаксис этого языка интуитивно понятен даже тем, кто только начинает осваивать азы программирования.
Язык Паскаль удобен для начального обучения программированию, не только
потому, что учит как правильно написать программу, но и тому, как правильно
разрабатывать методы решения задач программирования
Алфавит языка
- прописные и строчные буквы латинского алфавита от A до z ,
- а также символ подчеркивания ( _ ), который тоже считается буквой.
- Прописные и строчные буквы взаимозаменяемы (рАвНоЗнАчНы);
- арабские цифры 0 1 2 3 4 5 6 7 8 9 ;
- специальные одиночные знаки: + – * / = . , : ; ^ $ # @ ;
- специальные парные знаки: [ ] ( ) { } ;
- составные знаки : = .. ( * * ) ( .. ) .
Структура программы
- Программа на языке Паскаль состоит из:
// Заголовок (необязательная часть)
// Блок описаний
// Тело программы
Блок описаний
- Описание меток;
- Определение констант;
- Определение типов;
- Описание переменных;
- Описание процедур и функций.
Тело программы
Begin
………… { тело программы, список команд }
End.
Структура программы
Program NameProgram ; { заголовок программы }
Const … ; { раздел описания констант }
Var … ; { раздел описания переменных }
BEGIN ... { раздел операторов }
END.
Пояснения
В пояснениях можно использовать русские буквы
{ могут находится в фигурных скобках }
// могут писаться после двух слэшей
Оператор вывода
Write(‘ текст ’); - оператор вывода текста и переменных на экран (оставляет курсор на текущей строке);
Writeln(‘ текст ’); - оператор вывода текста и переменных на экран (переносит курсор на новую строку);
Компиляция ( F9)
- Устранение ошибок в программе.
Пример программы
Begin
write(‘ Это моя первая программа! ’);
End.
Произведите компиляцию и запустите программу на исполнение просмотрите результат.
Остановка выполнения программы
! Обратите внимание на то, что текст выводится в две разные строчки, т.е. необходимо использовать 2 оператора writeln(). " width="640"
Задание 001
- Выведите следующий текст на экран:
Привет всем!
Меня зовут имя !
Обратите внимание на то, что текст выводится в две разные строчки, т.е. необходимо использовать 2 оператора writeln().
Арифметические действия
- Если в программе записать:
Writeln(‘3+8’);
То после исполнения программы в экране выполнения появится надпись 3+8
Если же записать:
Writeln(3+8); // без апострофов
То после исполнения программы в экране выполнения появится надпись 11 , т.е. Pascal произведет сам расчёт
Попробуйте вычислить выражение: 185 * (14+16)

Презентация "Первая программа Pascal ABC" (348.5 KB)