Меню
Разработки
Разработки  /  Информатика  /  Презентации  /  9 класс  /  Презентация по информатике "Ветвления на Паскале"

Презентация по информатике "Ветвления на Паскале"

Презентация по учебнику И.Г. Семакина познакомит учащихся с видами ветвлений и операторами.
14.10.2014

Описание разработки

Презентация подготовлена ко второму уроку изучения темы "Ветвления на Паскале", когда учащиеся уже рассмотрели виды ветвлений и операторы, реализующие каждый из видов, а также попробовали решить несколько задач на ветвление. В начале урока происходит повторение изученного материала, затем - разбор задач из 1 и 2 уровней сложности.

Вопросы:

Какой алгоритм мы называем разветвляющимся?

Какие виды ветвления вам известны?

С помощью какого оператора на Паскале записывается ветвление?

Как на Паскале можно записать сразу 2 условия?

презентация ветвления на паскале

Задача А4.

Дано целое число А. Если значение А > 0, то необходимо увеличить его на единицу, иначе уменьшить на 1. Написать программу для решения этой задачи.

Программа должна иметь дружественный интерфейс. Протестировать программу для A=3, A=0, A=-12.

Содержимое разработки

Ветвления на Паскале 9 класс

Ветвления на Паскале

9 класс

Вопросы: Какой алгоритм мы называем разветвляющимся? Какие виды ветвления вам известны? С помощью какого оператора на Паскале записывается ветвление? Как на Паскале можно записать сразу 2 условия?

Вопросы:

  • Какой алгоритм мы называем разветвляющимся?
  • Какие виды ветвления вам известны?
  • С помощью какого оператора на Паскале записывается ветвление?
  • Как на Паскале можно записать сразу 2 условия?
0 , то необходимо увеличить его на единицу , иначе уменьшить на 1 . Написать программу для решения этой задачи. Программа должна иметь дружественный интерфейс . Протестировать программу для A=3, A=0, A=-12 . " width="640"

Задача А4

Дано целое число А . Если значение А 0 , то необходимо увеличить его на единицу , иначе уменьшить на 1 . Написать программу для решения этой задачи. Программа должна иметь дружественный интерфейс . Протестировать программу для A=3, A=0, A=-12 .

0 then A:=A+1 else A:=A-1; writeln(A); end. " width="640"

Решение задачи А4

var A: integer;

begin

writeln(‘Введи число’);

readln(A);

if A0 then A:=A+1 else A:=A-1;

writeln(A);

end.

Задача В1 Даны два действительных числа X и Y , не равные друг другу. Заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением. Программа должна иметь дружественный интерфейс .

Задача В1

Даны два действительных числа X и Y , не равные друг другу. Заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением. Программа должна иметь дружественный интерфейс .

Y then writeln(‘X:=‘,2*X*Y,’ Y:=‘,(X+Y)/2) else writeln(‘Y:=‘,2*X*Y,’ X:=‘,(X+Y)/2); end. " width="640"

Решение задачи В1

var X,Y: real;

begin

writeln(‘Введи первое число X’);

readln(X);

writeln(‘Введи второе число Y’);

readln(Y);

if XY then writeln(‘X:=‘,2*X*Y,’ Y:=‘,(X+Y)/2)

else writeln(‘Y:=‘,2*X*Y,’ X:=‘,(X+Y)/2);

end.

-80%
Курсы дополнительного образования

Основы HTML

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Презентация по информатике "Ветвления на Паскале" (0.11 MB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт