Меню
Разработки
Разработки  /  Информатика  /  Проверочные работы  /  Практические работы по Паскалю

Практические работы по Паскалю

Работа содержит 9 практических работ по Borland Pascal.
30.03.2015

Описание разработки

Тема: «Работа в среде программирования. Запуск программ на исполнение»

Цель:

Знакомство со средой программирования Borland Pascal. Развитие навыков применения Главного меню, умения сохранять и открывать созданные файлы, работать с фрагментами текста.

Основные приемы и методы:

1. Для загрузки Borland Pascal воспользуйтесь ярлыком на Рабочем столе или Bpascal ® Bin ® bp.exe .

2. Чтобы выбрать нужную команду из главного меню воспользуйтесь клавишей F10 или мышью.

3. Для открытия программы нужно: File ® Open ® имя файла.

4. Для перемещения по элементам окна диалога применяют клавишу ТАВ или мышь.

5. Запуск программы на исполнение – Ctrl + F9.

6. Чтобы начать набирать текст новой программы, нужно из меню File выбрать команду New (Новый). В результате этих действий будет открыто окно редактора текста, в котором можно набрать текст программы.

7. Для сохранения файла нужно: File ® Save. Затем в Поле ввода  введите имя файла и нажмите ОК.

8. Команды, используемые при работе с фрагментами текста, находятся в меню Edit (Правка). Перед выполнением действий с фрагментом текста  этот фрагмент нужно выделить.

9.  Чтобы переместить выделенный фрагмент текста , нужно:

Edit ® Cut (Вырезать). В результате этого выделенный фрагмент текста будет удален с экрана и помещен во внутренний буфер редактора. Затем установите курсор за тем символом текста, после которого нужно поместить выделенный фрагмент текста и из меню Edit выберите команду Paste (Вставить).

10. Чтобы скопировать выделенный фрагмент текста, нужно:

Edit ® Copy (Копировать). Затем установите курсор за тем символом текста, после которого нужно поместить копию выделенного фрагмент текста и из меню Edit выберите команду Paste ( Вставить).

11. Чтобы удалить выделенный фрагмент текста, нужно: Edit ® Clear (Очистить).

Задание:

Практические работы по Паскалю

1. Загрузите среду Borland Pascal.

Откройте  программу «Контроль веса» (optves.pas). Запустите программу на исполнение, введя необходимые данные.  

2. Составить программу вывода на экран приветствия будущему программисту.

Наберите новую программу согласно образцу и запустите ее на исполнение:

program Z1;

Var a: string;

begin

write (‘введите свою фамилию и нажмите ENTER’);

readln (a);

writeln (‘Привет’, a , ‘- будущий программист’);

end.

4. Сохраните файл под именем hello.pas

5. Выделите строку с командой writeln , скопируйте ее и  вставьте перед командой end.

6. Запустите программу вновь и посмотрите на результат работы.

(на экране появятся 2 приветствия).

7. Удалите из программы вставленный фрагмент.

8. Поменяйте строки местами, переместив фрагмент приветствия на строку выше.

Что произойдет с программой? Какой вывод можно сделать?

9. Верните фрагмент на прежнее место и вновь запустите программу.

10. Добавьте к программе согласно образцу командную строку, которая  после приветствия выведет на экран фразу «гордость СОШ № 14 г. Евпатории».

11. Вставьте недостающие знаки препинания.

Весь материал - в архиве.

-80%
Курсы дополнительного образования

Основы HTML

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Сохранить у себя:
Практические работы по Паскалю (60.05 КB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт