Меню
Разработки
Разработки  /  Информатика  /  Практикумы  /  8 класс  /  Pascal Знакомство с языком. Линейный алгоритм. Практическая 1

Pascal Знакомство с языком. Линейный алгоритм. Практическая 1

Практическая работа 1. Ввод и вывод данных. Решение простой задачи с линейным алгоритмом. Выполняется за компьютером. PascalABC, Pascal ABC.NET
24.04.2021

Содержимое разработки

Практическая работа 1

Тема: Знакомство со средой ABS Pascal. Операторы ввода-вывода

Задание:

  1. Задание 1.

    1. Выполните Задание 1 в среде ABS Pascal.

    2. Сохраните результат в своей папке.

    3. Покажите результат работы программы учителю.

  2. Задание 2.

    1. Выполните Задание 2 по своему варианту (номер в журнале).

    2. Оформите отчет по шаблону в файле
      x:\8 класс\Отчет по практической работе паскаль.docx

    3. Покажите результат работы программы учителю.

  3. Оценка “5” если выполнены два задания, оформлен отчет по Заданию 2
    “4”- сдано Задание 1, отлажена программа Задание 2 без отчета;
    “3” – выполнено только первое задание.


Задание 1

  • Составьте программу по образцу, используйте свое Ф.И. и класс;

  • Выполните программу в среде ABС Pascal.NET;

  • Исправьте ошибки;

  • Введите значения.

  • Покажите результат учителю.

Образец:

Program lab1;

var

year, b_year, age: integer ;

begin

writeln;

writeln(' Автор - ?????? ?, класс .????');

writeln(' Вариант №0');

writeln('Программа запрашивает значение текущего года и года рождения');

writeln('Вычисляет количество лет');

writeln;

write('Какой сейчас год? ');

readln ( year);

write('В каком году вы родились? ');

readln (b_ year);

age := year - b_ year;

write('В ', year, 'году мне исполнится ', age,'лет. ');

end.








Варианты задания 2

Составить программу

  • программа должна выводить на экран ФИ и класс учащегося.

  • программа должна выводить на экран задание.

  • значение вводится с клавиатуры.

Оформите отчет по Заданию 2


Вариант выбрать по номеру рабочего места.

1. Вычислите среднее арифметическое двух чисел

2. Вычислите среднее арифметическое трех чисел

3. Заданы стороны квадрата. Вычислить периметр

4. Заданы стороны квадрата. Вычислить площадь

5. Заданы стороны прямоугольника. Вычислить периметр

6. Заданы стороны прямоугольника. Вычислить площадь

7. Заданы стороны треугольника. Вычислить периметр

8. Заданы стороны треугольника. Вычислить площадь

10. Заданы стороны куба. Вычислить объем

11. Заданы площадь основания и высота цилиндра. Вычислить объем цилиндра. Объем цилиндра равен V=S*h

12. Заданы площадь основания и высота конуса. Вычислить объем конуса. Объем конуса равен V=S*h/3

-80%
Курсы дополнительного образования

Основы HTML

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Сохранить у себя:
Pascal Знакомство с языком. Линейный алгоритм. Практическая 1 (23.98 KB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт