Меню
Разработки
Разработки  /  Информатика  /  Практикумы  /  9 класс  /  Обобщение по теме "Массивы целых чисел"

Обобщение по теме "Массивы целых чисел"

Практическая работа для учащихся 9 класса по теме «Одномерные массивы целых чисел». Ориентирована на материал параграфа 2.2 учебника по информатике для 9 класса. Может быть использована самостоятельно учащимися в рамках дистанционного обучения, либо в конце изучения темы. Содержит задачу позволяющую реализовать основные действия с массивами, такие как ввод, заполнение и вывод массива, который учащийся должен освоить в рамках изучения данной темы.

14.04.2019

Содержимое разработки

Написать программу, которая Создает и заполняет 3 массива из 10 целочисленных значений: массив A - через раздел констант, числами от 1 до 10 массив B -  случайными числами, от 0 до 55 массив C - произвольными числами с клавиатуры массив A - через раздел констант, числами от 1 до 10 массив B -  случайными числами, от 0 до 55 массив C - произвольными числами с клавиатуры Вычисляет сумму элементов массива А Находит наибольший элемент в массиве В Сортирует по возрастанию массив С Все результаты должны быть выведены на экран одновременно!

Написать программу, которая

  • Создает и заполняет 3 массива из 10 целочисленных значений:
  • массив A - через раздел констант, числами от 1 до 10 массив B - случайными числами, от 0 до 55 массив C - произвольными числами с клавиатуры
  • массив A - через раздел констант, числами от 1 до 10
  • массив B - случайными числами, от 0 до 55
  • массив C - произвольными числами с клавиатуры
  • Вычисляет сумму элементов массива А
  • Находит наибольший элемент в массиве В
  • Сортирует по возрастанию массив С

Все результаты должны быть выведены на экран одновременно!

Program massiv; const a: array [1..10] of integer = (1,2,3,4,5,6,7,8,9,10); var  b,c: array [1..10] of integer;  i:integer; begin randomize; for i:=1 to 10 do b[i]:=random (56); for i:=1 to 10 do read (c[i]); for i:=1 to 10 do write (b[i],' '); end .

Program massiv;

const a: array [1..10] of integer = (1,2,3,4,5,6,7,8,9,10);

var b,c: array [1..10] of integer;

i:integer;

begin

randomize;

for i:=1 to 10 do b[i]:=random (56);

for i:=1 to 10 do read (c[i]);

for i:=1 to 10 do write (b[i],' ');

end .

-75%
Курсы повышения квалификации

Использование информационных технологий в процессе обучения в условиях реализации ФГОС

Продолжительность 72 часа
Документ: Удостоверение о повышении квалификации
4000 руб.
1000 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Обобщение по теме "Массивы целых чисел" (81.85 KB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт