Меню
Разработки
Разработки  /  Информатика  /  Проверочные работы  /  9 класс  /  Контрольная работа по информатике "Программирование в Паскаль"

Контрольная работа по информатике "Программирование в Паскаль"

Работа содержит различные задания, представленные в двух вариантах.
16.03.2014

Описание разработки

Задания состоят из следующих типов:

1) на трассировку линейных, разветвляющихся, циклических алгоритмов, работу с массивами*

2) составление программ на разветвляющихся циклический алгоритмов, работу с массивами, графические возможности языка программирования Паскаль.

*Часть заданяи подготвлена на основе открытого банка задач по ГИА и ЕГЭ по инфоматике.

1. Вычислите значение в линейных и разветвляющихся алгоритмах

А) а := 4

b := 4

а := 2*а + 3*b

b := a/2*b

b - ?

контрольная работа программирование паскаль

Весь материал - сомтрите документ.

Содержимое разработки

Контрольная работа по теме «Обработка информации» 9 класс

I вариант

  1. Вычислите значение в линейных и разветвляющихся алгоритмах

    А) а := 4

    b := 4

    а := 2*а + 3*b

    b := a/2*b

    Б) a := 30;

    b := 6;

    a := a / 2 * b;

    if a b then c := a - 3 * b else c := a + 3 * b;

    В) a := 3 + 8*4;

    b := (a div 10) + 14;

    a := (b mod 10) + 2;

    c := a + b;

    b - ?

    c -?

    c -?

  2. Вычислите значение в циклических алгоритмах

А) Var s,k: integer;

Begin

s := 0;

for k := 3 to 8 do

s := s + 9;

writeln(s);

End.

Б) Var k, i: integer;

Begin

k := 4;

For i := 1 to 3 do

k := i + 2*k;

Writeln(k);

End.

В) var n, s: integer;

begin

n : = 30; s : = 25;

while s

s : = s + 40;

n : = n + 10

end; write(n);end.

3. Вычислить значения обработки массива

А) Var k, m: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 2; Dat[2] := 5;

Dat[3] := 7; Dat[4] := 5;

Dat[5] := 4; Dat[6] := 2;

Dat[7] := 0; Dat[8] := 2;

Dat[9] := 4; Dat[10] := 5;

m := 0;

for k := 1 to 10 do

if Dat[k] 3 then

begin

m := m+1

end;

writeln(m);

End.

Б) Var k, m, month: integer;

Dat: array[1...12] of integer;

Begin

Dat[1] := 5; Dat[2] := 5; Dat[3] := 6;

Dat[4] := 8; Dat[5] := 4;Dat[6] := 5;

Dat[7] := 4; Dat[8] := 7;Dat[9] := 4;

Dat[10] := 4;Dat[11] := 8;Dat[12] := 7;

month: = 1; m := Dat[1];

for k := 2 to 12 do

if Dat[k]

begin

m:= Dat[k];

month := k;

end;

write(month);

End.


  1. По данной блок-схеме ставить программу вычисления b.


  1. 5. По данному условию ставить программу вычисления y.

  2. Заполнить случайным образом массив из 20 чисел элементами от 0 до 100, найти количество чисел кратных 15.

  3. Нарисуйте в координатной плоскости ракету и напишите программу ее рисования в Паскаль.






Контрольная работа по теме «Обработка информации» 9 класс

II вариант

  1. Вычислите значение в линейных и разветвляющихся алгоритмах

    А) b := -5

    a := 2

    а := 11 - 2*a - b

    b := a/3 - 3*b

    Б) a : = 50 ;

    b : = 6;

    a : = a * 3 / b

    if a b then с = a + 5 * b else с = a - 5 * b;

    В) x:= 8 + 2*5;

    y:= (x mod 10) + 14;

    x:= (y div 10) + 3;

    c:= x - y;

    b - ?

    c -?

    c -?

  2. Вычислите значение в циклических алгоритмах

    А) Var s,k: integer;

    Begin

    s := 0;

    for k := 3 to 8 do

    s := s + 9;

    writeln(s);

    End.

    Б) Var k, i: integer;

    Begin

    k := 4;

    For i := 1 to 3 do

    k := i + 2*k;

    Writeln(k);

    End.

    В) var n, s: integer;

    begin

    n : = 60;s : = 25;

    while s

    s : = s + 20;

    n : = n + 10

    end;write(n);end.

  3. Вычислить значения обработки массива

А) Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 12; Dat[2] := 15;

Dat[3] := 17; Dat[4] := 15;

Dat[5] := 14; Dat[6] := 12;

Dat[7] := 10; Dat[8] := 13;

Dat[9] := 14; Dat[10] := 15;

m := 0;

for k := 1 to 10 do

if Dat[k] = 15 then

begin

m := m+1;

end;

writeln(m);

End.

Б) Var k, m, day: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 2; Dat[2] := 2;Dat[3] := 3;

Dat[4] := 3; Dat[5] := 4; Dat[6] := 4;

Dat[7] := 5; Dat[8] := 5; Dat[9] := 6;

Dat[10] := 6;

day:=1; m := Dat[1];

for k := 2 to 10 do

if Dat[k] = m then

begin

m:= Dat[k];

day := k;

end;

write(day);

End.

  1. По данной блок-схеме ставить программу вычисления b.

  1. 5. По данному условию ставить программу вычисления y.

  2. Заполнить случайным образом массив из 30 чисел элементами от 0 до 500, найти количество чисел кратных 20.

  3. Нарисуйте в координатной плоскости конфету и напишите программу ее рисования в Паскаль..



-80%
Курсы повышения квалификации

Компьютерная грамотность для учителей

Продолжительность 72 часа
Документ: Удостоверение о повышении квалификации
4000 руб.
800 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Контрольная работа по информатике "Программирование в Паскаль" (26.82 КB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт