Вариант 1
1. Определите значение переменной a после исполнения данного алгоритма.
a = 8; b = 6+3*a; a= b/3*a;
что будет напечатано в результате работы следующей программы
2. a= 7; b= 15;
a = 2 * (–a) + b * 2;
if (a > b) c = a – b
else c = b – a;
cout << c;
3.
s=0;
for (i=2; i<=10;i++) s += i;
cout << s;
4. { n = 0; s = 0;
while (s <= 256) { s += 25; n += 5; }
cout <
}
Вариант 2
1. Определите значение переменной a после исполнения данного алгоритма.
a = 16; b = 12 – a / 4; a = a + b * 3;
что будет напечатано в результате работы следующей программы
2. a = 30; b = 6;
a = a * 3 / b;
if (a > b) c = a + 5 * b
else c = a - 5 * b;
cout << c;
3. n = 0; s = 0;
while (s <= 256) { s += 25; n += 3 }
cout << n;
4. { s=50;
for (k=0; k< 9; k++) s –= 4;
cout << s;
}
Полную информацию смотрите в файле.