Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Цикл While (Pascal)

Цикл While (Pascal)

Avatar
14.03.2021. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Цикл While (Pascal) (программирование циклов с заданным числом повторений)

Список вопросов теста

Вопрос 1
  1. Какой результат будет получен после выполнения фрагмента программы:

a:=9, b:=8, c:=2

if (a>b) and (b>c) then x:=2*a+b+c

                   else x:=a-b+c;

Вопрос 2
  1. Определите, что будет напечатано в результате работы следующего фрагмента программы:

var k, s: integer;

begin
s:=0;

k:=0;

      while s < 80 do begin

                  s:=s+2*k;

                     k:=k+4;

                     end;

write(s);

end.

Вопрос 3
  1. Определите значение переменной s после выполнения программы:

var s,i:integer;
begin
s:=0; i:=0;
while i<5 do begin

             i:=i+1;

             s:=s+2*i;

             end;
writeln(s);
end.

Вопрос 4
  1. Установите, что будет выведено на экран в результате выполнения следующей программы:

var n,x:integer;

begin

n:=2;

while n<=10 do n:=n*n;

writeln(n);

end.

Вопрос 5
  1. Определите значение переменной s после выполнения программы:

var s,i:integer;
begin
s:=0; i:=10;
while i>5 do begin
             i:=i-1;
             s:=s+i;

             end;

writeln(s);
end.

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт