1. Определите значение переменной k, после выполнения фрагмента программы:
n: = 'Обработка строк в Паскаль';
k: = length (n);
write (k);
Ответ: ________________________________
2. Определите результат работы следующего фрагмента программы:
n: = 'Обработка строк в Паскаль';
delete (n, 10, 8);
write (n);
Ответ: ________________________________
3. Определите результат работы следующего фрагмента программы:
n: = 'Обработка строк в Паскаль';
insert ('оч', n, 8);
write (n);
Ответ: ________________________________
4. Определите результат работы следующего фрагмента программы:
n: = 'Обработка строк в Паскаль';
k: = copy (n, 19, 7);
write (k);
Ответ: ________________________________
5. Определите результат работы следующего фрагмента программы:
n: = 'Обработка строк в Паскаль';
k: = copy (n, 1, 1);
delete (n, 1, 20);
insert (k, n, 0);
delete (n, 6, 1);
write (n);
Ответ: ________________________________
6. Определите значение переменной k, если
n: = 'Обработка строк в Паскаль';
for i: = 1 to length (n) do
if n[i] = 'а' then inc (k);
write (k);
Ответ: ________________________________
7. Определите результат работы следующего фрагмента программы:
n: = 'Обработка строк в Паскаль';
for i: = 1 to length (n) do
if n[i] = 'о' then n[i]: = ' ';
write (n);
Ответ: ________________________________

8. Определите начальные значения переменных a и b, если поле выполнения фрагмента программы программа вывела на экран “Привет! Как дела?” (без кавычек)?
c: = b + a;
insert (' Как ', c, 8);
write (c);
Ответ: ________________________________
9. Какую фразу можно записать в переменную x, чтобы после выполнения фрагмента программы переменная k приняла значение 6? Можно написать пример.
k: = 10;
for i: = 1 to length (x) do
if x[i] = ' ' then dec (k);
write (k);
Ответ: ________________________________
10. Что будет выведено на экран после выполнения программы?
var
s: string;
i: integer;
begin
s:='S';
for i: = 1 to 3 do
s: = s + 'о';
write (s + 'S');
end.
Ответ: ________________________________
Полную информацию смотрите в файле.

Тест по информатике на тему "Обработка строк в Pascal" (0.15 MB)

