Основные понятия.
Как и любой алгоритм, являющийся последовательностью инструкций, программа на языке Паскаль состоит из команд (операторов), записанных в определенном порядке и формате.
Команды позволяют получать, сохранять и обрабатывать данные различных типов (например, целые числа, символы, строки символов, т.д.).
Кроме команд в записи программы участвуют еще так называемые "служебные слова", организующие структуру программы.
(слайд 1.) Вам уже известно, что основное назначение компьютера – облегчить человеку работу с большими объемами информации, поэтому подавляющее большинство программ построено по одному, довольно простому принципу:
Все эти действия реализуются через имеющиеся в языках программирования команды, алгоритмические структуры и структуры данных.
Основная структура программы.
(слайд 2) Правила языка Паскаль предусматривают единую для всех программ форму основной структуры:
Program <Имя программы>;
<Раздел описаний>;
Begin
<Тело программы>;
End.
Здесь слова Program, Begin и End являются служебными. Правильное и уместное употребление этих слов является обязательным.
Угловые скобки в формате указывают на то, что вместо них при реальном программировании должно быть подставлено конкретное значение. Сама запись программы в принципе может производиться вообще в одну стоку. Однако, такая запись неудобна для чтения, недостаточно наглядна, поэтому я рекомендую придерживаться приведенной структуры, а в «теле» программы – по одному оператору в строке.
Имя программы выбирается самостоятельно разработчиком в соответствии с правилами построения идентификаторов.
Все объекты (переменные, константы метки, функции, процедуры и т.д.), не являющиеся зарезервированными в Паскале, которые вы используете в программе, должны быть описаны. Это производится для того, чтобы компьютер перед выполнением программы зарезервировал память под соответствующие объекты и поставил в соответствие им идентификаторы. Раздел описаний может состоять из пяти подразделов:
Описание меток (Label)
Описание типов (Type).
Описание констант (Const).
Описание переменных (Var).
Описание процедур и функций (Procedure, Function).
При отсутствии таких объектов, соответствующий подраздел может быть опущен.
(слайд 3) Алфавит языка.
Основу любого языка составляет алфавит, то есть конечный, фиксированный набор символов, используемых для составления текстов на данном языке (в нашем случае - программ).
Итак, алфавит языка Паскаль составляют:
буквы латинского алфавита; (Вопрос: Сколько букв? Ответ: 26)
арабские цифры; (Вопрос: Сколько цифр? Ответ: 10)
специальные знаки. (Вопрос: Кто подскажет? Ответ:.,;:<> и т.д.)
Использование символов первой группы чаще всего вопросов не вызывает, но свои тонкости здесь имеются.
Во-первых, это употребление заглавных и строчных букв. Большинство существующих трансляторов не различают буквы разных регистров. Таким образом, записи "progRaM" и "PROGram" будем считать идентичными.
(слайл 4) Во-вторых, некоторые символы латиницы и кириллицы совпадают по начертанию. Нельзя ли вместо буквы "К" латинской написать "K" русскую?
(Ожидаемый ответ: в программе на ЭВМ – ни в коем случае. На вид они может быть и похожи, но уж коды-то у них совершенно разные, а компьютер, как вам известно, оперирует внутри себя не буквами, а их числовыми кодами).
По поводу привычных арабских цифр сказать можно только то, что с их помощью записываются не только числа. Цифры могут использоваться в качестве обыкновенных символов.
Сложнее всего обстоит дело со специальными знаками, поэтому их придется разобрать подробно:
. конец программы, разделение целой и дробной частей вещественного числа (десятичная точка), разделение полей в переменной типа Record;
, разделение элементов списков;
.. указание диапазона;
: используется в составе оператора присваивания:=, а также для указания формата вывода в операторе Writeln;
; отделяет один раздел программы от другого, разделяет операторы;
' используется для ограничения строковых констант;
- + * / () арифметические знаки;
< > знаки отношений;
= используется в составе оператора присваивания, в разделах описаний констант и типов, используется как знак отношения (равно) ;
^ используется для именования динамических переменных;
{} ограничение комментариев в программе;
[ ] заключают в себе индексы элементов массивов;
_ символ подчеркивания используется также как любая буква, например, в идентификаторах - вместо пробела.
В процессе изучения языка мы познакомимся с этими знаками.
Возникает вопрос, а как же быть с русскими буквами и другими знаками, имеющимися на клавиатуре? Некоторые версии Паскаля допускают их использование в программе, но стандарт языка этого не подразумевает. Поэтому включать эти символы в программу можно только в качестве строковых констант или внутри комментария, то есть там, где транслятор при компиляции их игнорирует.
Идентификаторы.
Имена операторов, переменных, констант, типов величин, имя самой программы назначаются разработчиком и называются в Паскале идентификаторами. Существуют правила, которым должны отвечать все идентификаторы:
идентификатор должен быть уникальным, то есть одним и тем же именем разные объекты не могут быть названы;
идентификатор имеет ограничение по длине (зависит от конкретной реализации языка на компьютере) ;
(слайд 5) идентификатор может состоять только из символов латинского алфавита, цифр и знака подчеркивания ("_") ;
идентификатор не может начинаться с цифры.
Например, можно записать имя программы:
Iwanow_Petr_10a,
но нельзя: 10а-Иванов Петр (допущены три ошибки: имя начинается цифрой, использовано тире и слова разделены пробелом).
Нельзя использовать как идентификаторы слова, предназначенные для обозначения операторов программы, но можно программу оставить без заголовка.
Понятие переменной и типы данных рассмотрим на следующих уроках.
Раздел операторов.
Это основной раздел программы – выполнение программы сводится к выполнению раздела операторов, т.е. к выполнению последовательности операторов, заключенных в
операторные скобки begin….. end.
Оператор вывода.
Для вывода информации в Паскале используется оператор:
Write (b1, b2, b3,…, bn) ;
выводится на экран значения переменных b1, b2, b3,…, bn
Writeln (b1, b2, b3,…, bn) ;
(слайд 6) выводится на экран значения переменных b1, b2, b3,…, bn и после этого осуществляется переход на новую строку
Writeln;
переход на новую строку
Write (‘значения переменных’, b1, b2, b3,…, bn) ;
выводится на экран сообщение «значения переменных», затем соответствующие значения переменных b1, b2, b3,…, bn и после этого осуществляется переход на новую строку.