Меню
Разработки
Разработки  /  Информатика  /  Презентации  /  5 класс  /  Презентация по информатике "Арифметические операции на языке программирования Паскаль"

Презентация по информатике "Арифметические операции на языке программирования Паскаль"

Презентация знакомит учащихся с арифметическим операциями языка программирования Паскаль.
04.02.2014

Описание разработки

Презентация содержит 20 слайдов.

Презентация Арифметические операции на языке программирования Паскаль

Задача 1. Составить программу для нахождения периметра прямоугольника

Задача 2. Составить программу для нахождения суммы цифр двузначного числа.

Содержимое разработки

Арифметические операции на языке программирования паскаль Додохова К.А.

Арифметические операции на языке программирования паскаль

Додохова К.А.

Арифметические операции Вычитание Сложение Деление Умножение

Арифметические операции

Вычитание

Сложение

Деление

Умножение

СЛОЖЕНИЕ +

СЛОЖЕНИЕ

+

Вычитание -

Вычитание

-

Умножение *

Умножение

*

деление /

деление

/

 Задача 1. Составить программу для нахождения периметра прямоугольника

Задача 1. Составить программу для нахождения периметра прямоугольника

 PROGRAM PERIMETR; VAR a,b,P: integer;  BEGIN   Write(‘ введите стороны прямоугольника’);  Read(a,b); P:=(a+b)*2; Writeln(‘P=’,P); End.

PROGRAM PERIMETR;

VAR a,b,P: integer;

BEGIN

Write(‘ введите стороны прямоугольника’);

Read(a,b);

P:=(a+b)*2;

Writeln(‘P=’,P);

End.

Арифметические операции Деление с остатком Деление нацело

Арифметические операции

Деление с остатком

Деление нацело

Деление нацело div

Деление нацело

div

пример 5 div 2=2 Самостоятельно найдите: 1 5 div 3= 3 6 div 2= 1 7 div 7=

пример

5 div 2=2

Самостоятельно найдите:

1

5 div 3=

3

6 div 2=

1

7 div 7=

Деление с остатком mod

Деление с остатком

mod

пример 5 mod 2=1 Самостоятельно найдите: 2 5 mod 3= 0 6 mod 2= 1 7 mod 3=

пример

5 mod 2=1

Самостоятельно найдите:

2

5 mod 3=

0

6 mod 2=

1

7 mod 3=

пример (5 mod 2+4)*4-6 div 2*2=?

пример

(5 mod 2+4)*4-6 div 2*2=?

Приоритет арифметических операций Выполняются операции внутри скобок * / div mod + -

Приоритет арифметических операций

Выполняются операции внутри скобок

* / div mod

+ -

пример 1 2 3 4 6 5 14 (5 mod 2+4)*4-6 div 2*2=

пример

1

2

3

4

6

5

14

(5 mod 2+4)*4-6 div 2*2=

Найдите значение выражения: 2-13 mod 7/3= 0 14 div 3*2= 8 19 mod 5 div 2= 2 7 12 mod 7 +2= 20 mod 7 = 6 30 div 7 -3= 1 (4+5)-6 div 3= 7

Найдите значение выражения:

2-13 mod 7/3=

0

14 div 3*2=

8

19 mod 5 div 2=

2

7

12 mod 7 +2=

20 mod 7 =

6

30 div 7 -3=

1

(4+5)-6 div 3=

7

 Задача 2. Составить программу для нахождения суммы цифр двузначного числа.

Задача 2. Составить программу для нахождения суммы цифр двузначного числа.

 PROGRAM SUMMA; var a,b,c,s:integer;  BEGIN   Write(‘ введите двузначное число:’);  Read(a); b:=a mod 10; c:=a div 10; s:=b+c; Writeln(‘сумма цифр числа=’, s); End.

PROGRAM SUMMA;

var a,b,c,s:integer;

BEGIN

Write(‘ введите двузначное число:’);

Read(a);

b:=a mod 10;

c:=a div 10;

s:=b+c;

Writeln(‘сумма цифр числа=’, s);

End.

Спасибо за урок!

Спасибо за урок!

-80%
Курсы профессиональной переподготовке

Учитель, преподаватель информатики в начальной школе

Продолжительность 300 или 600 часов
Документ: Диплом о профессиональной переподготовке
13800 руб.
от 2760 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Презентация по информатике "Арифметические операции на языке программирования Паскаль" (0.12 MB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт