Практическая работа «Решение задач на Паскале. Линейные задачи»
Задача: ( Массив)
С клавиатуры вводятся N числа. Составьте программу, которая определяет количество положительных, отрицательных чисел и нулей среди введённых чисел. Значение N вводится с клавиатуры.
Program AAAAAA;
var i,n: integer;
s,c,k: real;
M:array[1..n1] of real;
begin
writeln('введи число элементов
readln(n);
writeln('введи элементы');
for i:=1 to n do read(M[i]);
s:=0; c:=0; k:=0;
for i:=1 to n do
begin
if M[i]
if M[i]0 then c:=c+1 else k:=k+1;
end;
writeln('колличество положительных чисел = ',c:2:0);
writeln('колличество отрицательных чисел = ',s:2:0);
writeln('колличество нулей = ',k:2:0);
readln;
readln;
end.
Составить массив из пяти фамилий, и вывести на экран столбиком, начиная с последней.
program fff;
var v:array[1..5] of string;
i:integer;
begin
writeln('введи пять фамилий');
for i:=1 to 5 do readln(v[i]);
writeln(' фамилии наоборот:');
for i:=5 downto 1 do writeln(v[i]);
readln;
end.
Задача: ( Массив с символьными переменными)
Составить массив из пяти фамилий, и вывести на экран те из них, которые начинаются с определённой буквы, которая вводиться с клавиатуры.
Длину строки можно указать в разделе описания переменных:
имя переменной, …:string[n]
program fff;
var v:array[1..5] of string;
k:string[1];
i:integer;
begin
writeln('введи букву, с которой будет начинаться фамилия');
readln(k);
writeln('введи пять фамилий');
for i:=1 to 5 do readln(v[i]);
writeln('интересующие Вас фамилии:');
for i:=1 to 5 do
if (v[i])[1]=k then writeln(v[i]);
readln;
end.
Из вводимого с клавиатуры слова вырезать каждую третью букву.
program aa;
var a:string;
k,x: integer;
begin
readln(a);
k:=length(a);
x:=3;
while x
begin
a[x]:=' ';
x:=x+3;
end;
writeln(a);
readln;
end.
В вводимом слове с клавиатуры заменить все буквы «а» на букву «о».
program aa;
var a:string;
k,x: integer;
begin
readln(a);
k:=length(a);
for x:=1 to k do
if a[x]='а' then a[x]:='о';
writeln(a);
readln;
end.
Заданны фамилия, имя, отчество учащегося, разделённые пробелами. Напишите программу, печатающую фамилии ученика и его инициалы.
program aaa;
uses crt;
var d,r:string;
k,i:integer;
begin
clrscr;
writeln('введи Ф.И.О.');
readln(d);
k:=length(d);
for i:=1 to k do
begin
if d[i]=' ' then d:=copy(d,1,i)+d[i+1]+'.';
end;
writeln(d);
readln;
end.
2)Определить, является ли строка палиндромом.