Цель- овладение практическими навыками разработки и программирования линейных вычислительных процессов и навыками по отладке и тестированию программ.
Ход работы:
Пример. треугольник задан координатами своих вершин. Составьте программу вычислния площади треугольника по формуле Герона.

Программа решения задачи будет иметь вид:
program1;
uses crt;
var x1,y1,x2,y2,x3,y3:real;
a,b,c:real;
p:real;
s: real;
begin
clrscr;
writeln('Введите координаты вершин треугольника');
writeln('x1=10,y1=15,x2=15,y2=20,x3=25,y3=30');
readln(x1,y1,x2,y2,x3,y3);
a:=sqrt(sqr(x2-x1)+sqr(y2-y1));
b:=sqrt(sqr(x3-x2)+sqr(y3-y2));
c:=sqrt(sqr(x3-x1)+sqr(y3-y1));
p:=(a+b+c)2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln;
writeln(' при координатах:x1=',x1:2’:3,'y1=',y1:2,’:3,'x2=',x2:2,’:3,'y2=',y2:2,":3,'x3=',x3:2,’:3,'y3=',y3:2);
writeln('Вычисление площади треугольника');
write('a=',a:4:2,":3,'b=',b:4:2,":3,'c=',c:4:2,":3,'p=',p:4:2,":3,'s=',s:6:3;
readln;
end.
Весь материал – смотрите документ.

ель- овладение практическими навыками разработки и программирования линейных вычислительных процессов и навыками по отладке и тестированию программ.

Практическая работа по информатике "Программирование алгоритмов линейной структуры" (37.5 КB)

