Меню
Разработки
Разработки  /  Информатика  /  Практикумы  /  8 класс  /  Pascal Знакомство с языком. Разветвляющийся алгоритм. Практическая 3

Pascal Знакомство с языком. Разветвляющийся алгоритм. Практическая 3

Практическая работа 3. Разветвляющийся алгоритм. Решение задачи с использованием компьютера. Pascal, PascalABC, PascalABC.NET.
24.04.2021

Содержимое разработки

Практическая работа 3

Тема: Программирование разветвляющихся алгоритмов

Задание:

  1. Задание 1.

    1. Выполните Задание 1 в среде ABС Pascal. NET

    2. Сохраните результат в своей папке.

    3. Покажите результат работы программы учителю.

  2. Задание 2.

    1. Выполните Задание 2 по своему варианту (номер в журнале).

    2. Оформите отчет по шаблону в файле
      x:\8 класс\Отчет по практической работе паскаль.docx

    3. Покажите результат работы программы учителю.

  3. Оценка “5” если выполнены два задания, оформлен отчет по Заданию 2
    “4”- сдано Задание 1, отлажена программа Задание 2 без отчета;
    “3” – выполнено только первое задание.

Задание 1

  • Составьте программу по образцу, используйте свое Ф.И. и класс;

  • Выполните программу в среде ABС Pascal.NET;

  • Исправьте ошибки;

  • Выполните программу для тестовых значений

Входные данные

Выходные данные

1 2 5 3

Точка А ближе

6 1 -3 -1

Точка Б ближе


  • Введите значения.

  • Покажите результат учителю.


Образец:


var x1,y1,x2,y2,d1,d2:real;

begin

writeln('введите A(X1,Y1) и B(X2,Y2));

readln( x1,y1,x2:2,y2 );

d1:=sqrt(sqr(y1)+sqr(x1));

d2:=sqrt(sqr(y2)+sqr(x2));

if d1Точка A ближе');

else if d1d2 then writeln('Точка B ближе')

else writeln('Одинаково);

end.


Задание 2

Составить программу

  • программа должна выводить на экран ФИ и класс учащегося.

  • программа должна выводить на экран задание.

  • Значение х вводится с клавиатуры.

  • Значение y выводиться в формате на 10 позиций, 3 знак после запятой.

  • Для работы использовать стандартные функции:

y:=sin(x) y:=cos(x)

xy= power(x,y)

tg(x) = sin(x)/cos(x)

= sqrt(x)

x2 = sqr(x)



-80%
Курсы дополнительного образования

Основы HTML

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Pascal Знакомство с языком. Разветвляющийся алгоритм. Практическая 3 (377.41 KB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт