Меню
Разработки
Разработки  /  Информатика  /  Практикумы  /  8 класс  /  Pascal Знакомство с языком. Линейный алгоритм. Практическая 2

Pascal Знакомство с языком. Линейный алгоритм. Практическая 2

Практическая работа 2. Линейный алгоритм. Решение более сложной задачи с использованием компьютера. Pascal, PascalABC, PascalABC.NET.
24.04.2021

Содержимое разработки

Практическая работа

Тема: Знакомство со средой ABС Pascal. NET Операторы ввода-вывода

Задание:

  1. Задание 1.

    1. Выполните Задание 1 в среде ABС Pascal. NET

    2. Сохраните результат в своей папке.

    3. Покажите результат работы программы учителю.

  2. Задание 2.

    1. Выполните Задание 2 по своему варианту (номер в журнале).

    2. Оформите отчет по шаблону в файле
      x:\8 класс\Отчет по практической работе паскаль.docx

    3. Покажите результат работы программы учителю.

  3. Оценка “5” если выполнены два задания, оформлен отчет по Заданию 2
    “4”- сдано Задание 1, отлажена программа Задание 2 без отчета;
    “3” – выполнено только первое задание.

Задание 1

  • Составьте программу по образцу, используйте свое Ф.И. и класс;

  • Выполните программу в среде ABС Pascal.NET;

  • Исправьте ошибки;

  • Выполните программу для тестовых значений

Входные данные

Выходные данные

5.5

2.3

12.65

15.6


  • Введите значения.

  • Покажите результат учителю.

Образец:

program pryamougolnik;

var

a, b, s, p; real;

begin

writeln;

writeln(' Автор - ?????? ?, класс .????');

writeln(' Вариант №0');

writeln ('Программа расчёта площади и периметра прямоугольника);

writeln(‘ по длине его сторон.');

write (a=);

readln (a);

write ('b=');

readln (b);

s:=a*b;

p=(a+b)*2;

write ('s=', s:5:2, ' p=', p:5:2);

end.




Варианты задания 2

Составить программу

➢ программа должна выводить на экран ФИ и класс учащегося.

➢ программа должна выводить на экран задание.

➢ значение вводится с клавиатуры.

  1. За решение четырех задач ученик получил оценки (от 1 до 5). Составьте программу, которая определит среднее значение оценок, полученных учеником за задачи.

  2. Четыре человека пообедали в ресторане. Официант подал каждому счет. Они решают оставить официанту чаевые в размере 15% от счета. Составить программу, которая выведет на экран сумму чаевых, которую получил официант.

  3. Сколько времени в минутах затратит школьник на дорогу из школы до стадиона, если известна длина этого расстояния S км и средняя скорость движения школьника v км/ч?

  4. Три четверти пассажиров самолета имеют билеты второго класса стоимостью X рублей каждый. Остальные пассажира имеют билеты первого класса, которые стоят в два раза дороже билетов второго класса. Напишите программу, которая выведет сумму денег, получаемую авиакомпанией от продажи билетов на этот рейс, если салон самолета рассчитан на V пассажиров.

  5. Вычислить длину окружности, площадь круга и объем шара одного и того же заданного радиуса.

  6. Дана длина ребра куба. Найти площадь грани, площадь полной поверхности и объем этого куба.

  7. Вычислить стороны правильных шестиугольников, описанных и вписанных в окружность известного радиуса.

  8. Вычислите расстояние между двумя точками с заданными координатами (x1 , y1) и (x2 , y2).

  1. По координатам трёх вершин некоторого треугольника найти его площадь и периметр.

  2. Скорость первого автомобиля v1 км/ч, второго - v2 км/ч, расстояние между ними s км. Какое расстояние будет между ними через t ч, если автомобили движутся в разные стороны?

  3. Найдите площадь кольца, внутренний радиус которого равен r, а внешний – R (Rr).


-75%
Курсы профессиональной переподготовке

Учитель, преподаватель информатики в начальной школе

Продолжительность 300 или 600 часов
Документ: Диплом о профессиональной переподготовке
13800 руб.
от 3450 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Pascal Знакомство с языком. Линейный алгоритм. Практическая 2 (25.96 KB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт