Меню
Разработки
Разработки  /  Информатика  /  Тесты  /  9 класс  /  Pascal. Условная функция

Pascal. Условная функция

Самостоятельная работа представлена из восьми заданий в двух вариантах.
02.10.2013

Описание разработки

1 вариант

1. К какому типу относится переменная А:=26?

а) char;  б) integer;    в) boolean;   г) real.

2. Определите, является ли число М четным. Какое условие можно использовать в этой задаче?

а) M mod 2=0;    б) M/2=0;    в) M div 2 =0;   

 г) M='четное'.

3. Входит ли число А в диапазон значений (4;10]? Какое составное условие нужно поставить в этой задаче?

а) (A>4) and (A<=10);   б) (A<4) and (A>=10);   

 в) (A>4) or (A<=10);     г) not (A>4) and not (A<=10).

4. Какое условие следует использовать для вычисления Y по формулам: Y=(X+1)2, при X<1; Y=cosX, при X≥1?

а) if x>=1 then y:=cos(x) else y:=sqr(x+1); 

 б) if x<1then y:=cos(x) else y:=sqr(x+1);   

в) if x>=1 then y:=sqr(x+1) else y:=cos(x);     

г) if x>1 then y:=cos(x) else y:=sqr(x+1);

5. Что будет выведено на экран после выполнения фрагмента программы?

begin

a:=1; b:=2;

if (a>=1) and (b>=2) then n:=a+b else n:=a-b;

writeln(n);

end.

а) 3;     б) -1;     в) 1;    г) 2.

6. Есть ли в следующих текстах пустые операторы? (В ответе перечислите буквы через запятую)

а) if x>0 then x:=3 else; y:=x-2   

б) if a mod b=0 then else b:=0   в) begin x:=2; y:=5; end   г) begin a:=true; b:=b or a end  

д) begin if x=0 then x:=2; y:=x

7.  Найдите ошибки в следующих операторах и запишите исправленные операторы.

а) begin if x2<1 then y:=sinx;

x:=x2 ; end;

б) if 0<x<2 then if y<1 then y=y+3 else y:=y2

else y:=sqr(y)

8. Напишите программу, которая по номеру месяца показывает номер квартала к которому он принадлежит.

Задания второго варианта - смотрите документ.

Содержимое разработки

Самостоятельная работа "Условная функция"

1 вариант

1. К какому типу относится переменная А:=26?

а) char; б) integer; в) boolean; г) real.

2. Определите, является ли число М четным. Какое условие можно использовать в этой задаче?

а) M mod 2=0; б) M/2=0; в) M div 2 =0;

г) M='четное'.

3. Входит ли число А в диапазон значений (4;10]? Какое составное условие нужно поставить в этой задаче?

а) (A4) and (Aб) (A=10);

в) (A4) or (Aг) not (A4) and not (A

4. Какое условие следует использовать для вычисления Y по формулам: Y=(X+1)2, при XY=cosX, при X≥1?

а) if x=1 then y:=cos(x) else y:=sqr(x+1);

б) if x

в) if x=1 then y:=sqr(x+1) else y:=cos(x);

г) if x1 then y:=cos(x) else y:=sqr(x+1);

5. Что будет выведено на экран после выполнения фрагмента программы?

begin

a:=1; b:=2;

if (a=1) and (b=2) then n:=a+b else n:=a-b;

writeln(n);

end.

а) 3; б) -1; в) 1; г) 2.

6. Есть ли в следующих текстах пустые операторы? (В ответе перечислите буквы через запятую)

а) if x0 then x:=3 else; y:=x-2

б) if a mod b=0 then else b:=0 в) begin x:=2; y:=5; end г) begin a:=true; b:=b or a end

д) begin if x=0 then x:=2; y:=x

7. Найдите ошибки в следующих операторах и запишите исправленные операторы.

а) begin if x2

x:=; end;

б) if 02

else y:=sqr(y)

8. Напишите программу, которая по номеру месяца показывает номер квартала к которому он принадлежит.



















Самостоятельная работа "Условная функция"

2 вариант

1. К какому типу относится переменная А:=0.25?

а) char; б) integer; в) boolean; г) real.

2. Определите, является ли число М нечетным. Какое условие можно использовать в этой задаче?

а) M mod 20; б) M/20; в) M div 20;

г) M='нечетное'.

3. Входит ли число А в диапазон значений [4;10)? Какое составное условие нужно поставить в этой задаче?

а) (A=4) and (Aб) (A10);

в) (A=4) or (Aг) not (A=4) and not (A

4. Какое условие следует использовать для вычисления Y по формулам: Y=(X+1)2, при X≥1; Y=cosX, при X

а) if x=1 then y:=cos(x) else y:=sqr(x+1);

б) if x

в) if x=1 then y:=sqr(x+1) else y:=cos(x);

г) if x1 then y:=cos(x) else y:=sqr(x+1);

5. Что будет выведено на экран после выполнения фрагмента программы?

begin

a:=1; b:=1;

if (a=1) and (b=2) then n:=a+b else n:=a-b;

writeln(n);

end.

а) 3; б) -1; в) 1; г) 0.

6. Есть ли в следующих текстах пустые операторы? (В ответе перечислите буквы через запятую)

а) begin a:=true; b:=b end

б) if a div b=0 then else b:=0 в) begin x:=-2; y:=-5; end г) begin if x=0 then x:=2; y:=x

д) if x0 then x:=3 else; y:=x-2

7. Найдите ошибки в следующих операторах и запишите исправленные операторы.

а) begin if y21 then y:=cosy;

y:=; end;

б) if -2=1 then y=y3 else y:=y2

else y:=sqr(y)

8. Напишите программу, которая по номеру дня недели показывает название этого дня недели.


-80%
Курсы дополнительного образования

Создание динамических веб-страниц с помощью PHP и MySQL

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Сохранить у себя:
Pascal. Условная функция (16.6 КB)

Комментарии 1

Чтобы добавить комментарий зарегистрируйтесь или на сайт

анатолий, 12.02.2016 11:56
hff