Меню
Разработки
Разработки  /  Информатика  /  Уроки  /  9 класс  /  Материал по информатике "Программирование линейных алгоритмов"

Материал по информатике "Программирование линейных алгоритмов"

Материал поможет в приобретении обучающимися опыта программирования линейных алгоритмов для дальнейшего применения полученных умений.
14.12.2014

Описание разработки

Цель урока

Приобретение обучающимися опыта программирования линейных алгоритмов для дальнейшего применения полученных умений при изучении блока «Программирование

Задачи урока

1. Повторить понятия алгоритма, линейного алгоритма и этапы построения линейных алгоритмов.

2. Провести сравнительный анализ графической записи линейного алгоритма и программы линейного алгоритма.

3. Отработать навыки программирования линейных алгоритмов

Материал по информатике Программирование линейных алгоритмов

8. Смогли выполнить? Почему?

9. Что нового? Умеем мы составлять Программу

Изучение нового материала

А я говорю, что можем.

Посмотрите на задачи №1 и №2. Пример одинаковый

Полную информацию смотрите в файле. 

Содержимое разработки

Технологическая карта урока


Предмет, класс

Информатика и ИКТ, 9 класс

Учитель

Зенцова Елена Николаевна

Тема урока,

урока по теме

«Программирование линейных алгоритмов»

(раздел «Алгоритмы и исполнители»)

17

Цель урока

Приобретение обучающимися опыта программирования линейных алгоритмов для дальнейшего применения полученных умений при изучении блока «Программирование»

Задачи урока

  1. Повторить понятия алгоритма, линейного алгоритма и этапы построения линейных алгоритмов.

  2. Провести сравнительный анализ графической записи линейного алгоритма и программы линейного алгоритма.

  3. Отработать навыки программирования линейных алгоритмов.

 

Тип урока

Открытие нового знания

Актуальность использования средств ИКТ


Необходимое аппаратное и программное обеспечение

Средства мультимедиа, ПК для учеников, среда программирования PascalABC.

Образовательные ресурсы Интернет

pascalabc.net


Дидактическая структура урока

Деятельность учителя

Деятельность учеников

Задания для учащихся, выполнение которых приведет к достижению планируемых результатов

Планируемые результаты

Предметные




УУД





Обучающиеся смогут:

Организационный момент

 Подготавливает задание на доске. Раздает таблицы.

 Включают ПК

 

 

 

Проверка домашнего задания

1. В чём заключается задание на доске?



Необходимо составить алгоритм 




 №1.

Составьте алгоритм для решения задачи:

 давать определение понятию алгоритм;





 


2. А что такое алгоритм?

Алгоритм – определённая последовательность действий для решения задачи.




3. А какого типа алгоритм мы получим?


Линейный




4. Что такое линейный алгоритм


Линейный алгоритм – последовательность действий, выполняемая в строгой последовательности.


 давать определение понятию линейный алгоритм;



Запишите в тетради число.

Запишите «Тема:» и оставьте место. Вы мне её скажите сами позже.

Производят записи в тетради



5. Выполните задание


Выполняют задание в тетради.


составлять блок схему линейного алгоритма;



6. У меня вот что получилось, а у вас?


Произведем анализ задачи: Найти: x,y,z Ввести: a,b,c,u



Проводят самоанализ решения задачи.



проводить самоконтроль при решении задач;


7. Выполните следующее задание


Пытаются выполнить задание

№2.

Составьте программу для решения задачи:




8. Смогли выполнить?

Почему?


Нет

Мы такого ещё не проходили.





9. Что нового?

Умеем мы составлять

Программу?

«Составить программу».

Нет




Изучение нового материала

А я говорю, что можем.

Посмотрите на задачи №1 и №2. Пример одинаковый?

 Да


Да

 

 

 

Вот так выглядит программа для нашего примера:


program zd1;

var a,b,c,x,y,z,u: real;

begin

readln(a,b,c,u);

z:=a*sqr(u)+b*u+c;

y:=a*sqr(z)+b*z+c;

x:=a*sqr(y)+b*y+c;

writeln(x, y, z);

end.


Давайте сравним наш алгоритм и программу.





Анализ:

1.Что такое program zd1;?

Компьютер должен знать, что мы собираемся писать программу.


Название программы



проводить сравнительный анализ и выделять закономерности;

2. Обратите внимание, какие переменные указаны в разделе var?


Посмотрите по таблице, что означает раздел var?


Совершенно верно.

Для всех переменных данного раздела компьютер подготавливает место в памяти и присваивает ему имя переменной. Именно в этом месте будет храниться её значение.

Не указанные в разделе описаний переменные не могут использоваться в программе

Которые указаны в анализе при составлении алгоритма.

Описание переменных



3. Что такое «begin» и «end?





Совершенно верно. Обратите внимание: в конце стоит точка. Она обязательна, т.к. говорит о том, что программа окончена.

Это наши

начало



и

конец





4. Посмотрите на readln(a,b,c,u);?

Скажите, в нашем алгоритме, чему это может соответствовать и что означать?




Какие данные вводим?


Данный оператор как называется (смотрит в раздаточной таблице)?


readln(a,b,c,u) соответствует

и означает ввод данных.

Те, что стоят внутри параллелограмма.

Оператор «Ввода».



5. Посмотрите на блок

z:=a*sqr(u)+b*u+c;

y:=a*sqr(z)+b*z+c;

x:=a*sqr(y)+b*y+c;

Скажите, в нашем алгоритме, чему это может соответствовать и что означать?




соответствует









и означает вычисления




6. Посмотрите на writeln(x, y, z);?

Скажите, в нашем алгоритме, чему это может соответствовать и что означать?




Какие данные выводим?


Данный оператор как называется (смотрит в раздаточной таблице)?

writeln(x, y, z);

соответствует

и означает вывод данных.

Те, что стоят внутри параллелограмма.

Оператор «Вывода».



7.Обратите внимание, что в конце каждой фразы стоит знак «;». Он означат, что фраза окончена и мы переходим к следующей мысли. А как называется этот оператор?

Какие ещё операторы, кроме тех, что мы уже назвали, здесь используются (смотрим в раздаточной таблице)?




Пустой оператор.

:= - оператор присваивания;

«begin…end» - составной оператор.




Смогли мы выполнить задание?

Давайте составим этапы создания программы.





Как выглядит структура линейного алгоритма?

Да.

  1. Провести анализ

  2. Составить алгоритм

  3. Записать алгоритм на языке программирования

  1. Название программы;

  2. описание переменных;

  3. ввод данных

  4. вычисления;

  5. вывод данных;


научиться выделять этапы и структуру программы линейного алгоритма;

уметь систематизировать свои знания;

Скажите, чем мы сейчас занимались?

А какие алгоритмы мы программировали?

Так какая сегодня тема?




Совершенно верно. Запишите тему.

Программировали.


Линейные алгоритмы.


«Программирование линейных алгоритмов»





Закрепление нового материала

 Выполните задание в парах:


Какая пара выполнила, можете приступать к вводу на ПК

 Выполняют задание в тетради

 №3.

Составьте программу для решения задачи:

 

приобрести навыки программирования линейного алгоритма;

 

 проводить самоконтроль при решении задач;

 

Контроль

 Загрузите систему программирования PascalABC.

В текстовом редакторе среды программирования введите текст программы и проведите её трассировку.

Если программа пошла, поднимите руку – вы сделали всё правильно.

 Выполняют задание на ПК

Рефлексия

Поднимите руки те, кто сегодня себя почувствовал программистом.

Поднимите руки те, кто сегодня понял, что он может программировать.

Поднимите руки те, кто сегодня пришел на урок.

Какие мы молодцы – мы все тянем руки отвечать! Значит мы все с вами тянемся к знаниям.

 

 

 

анализировать свои мысли и эмоции.


-80%
Курсы дополнительного образования

Создание динамических веб-страниц с помощью PHP и MySQL

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Материал по информатике "Программирование линейных алгоритмов" (36.42 КB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт