Меню
Разработки
Разработки  /  Информатика  /  Проверочные работы  /  Контрольные работы по программированию на языке Pascal

Контрольные работы по программированию на языке Pascal

Контрольные работы по программированию на языке Pascal по темам: Линейное программирование, Ветвление и выбор варианта, Циклические алгоритмы, Массивы.
27.03.2012

Описание разработки

Архив содержит контрольные работы по программированию на языке Pascal по темам: «Линейное программирование», «Ветвление и выбор варианта», «Циклические алгоритмы», «Массивы». Контрольные работы представлены в двух вариантах, каждый вариант состоит из двух частей. Первая часть – задания основного и среднего уровней в тестовой форме, где учащиеся должны выбрать один или несколько правильных ответов. Вторая часть – задания достаточного и высокого уровней сложности. Последние задания второй части необходимо выполнить на компьютере (составление программ).В контрольных работах предусмотрена двенадцатибалльная система оценивания.

Контрольные работы по программированию на языке Pascal

Контрольная работа. Массивы

Вариант 1

Часть I. Задания основного и среднего уровней (каждое задание по 0,5 балла)

1. Что такое массив?

А) Совокупность однотипных данных, хранящихся в последовательных ячейках памяти;

Б) Табличные данные; В) Набор данных, которые имеют порядковый тип; Г) Последовательность случайных чисел.

2. Индексом элемента называется…

А) Значение элемента массива;   Б) Последний элемент в массиве;  В) Номер элемента в массиве;

Г) Тип элемента

3. Массив данных имеет

А) Общее имя;  Б) Один тип;   В) Общее имя и один тип;  Г) Общее имя и разный тип

4. В записи D[4]=3.5, D обозначает…

А) Имя ячейки;   Б) Номер элемента в массиве;   В) Обозначение типа; Г) Имя массива

5. Какой ряд данных можно назвать массивом?

А) а, 4, б, 5, с, 6;  Б) 2.3, 5.7, 10.89;  В) 3, 6, 3, 2, massiv;   Г) 4, 8, 8.1, 9, 19

6. Найдите правильное описание массива.

А) D: array[1..5] of real;  Б) Array D: [1..5] of real; В) D[1..5]:array of integer; Г) D= array[1..5] of real

7. Для заполнения массива случайными числами мы должны подключить датчик случайных чисел, используя команду…

А) Clrscr;  Б) A[i]:=?;  В) Random(n);   Г) Raund (n)

8. Что выполняет следующий фрагмент программы: For i:=1 to N do write (a[ i ]);

А) Выводит N значений массива на экран;  Б) Производит ввод данных в массив;

В) Выполняет проверку значений элементов массива; Г) Сортировку массива

9. Для подсчета суммы элементов массива в цикле используем следующую запись…

А) Sum:=sum+a(i); Б) Sum:=a[i]+a[i+1];  В) Sum:=a[i]+sum; Г) Sum:=sum + i

10. Для подсчета количества положительных элементов массива будем использовать условие…

А) If a[i]>0 then k:k+1; Б) If a[i]>=0 then k:=k+a[i]; В) If a[i]>=0 then k:=k+1; Г) If a[i]>0 then k:=k+1

11. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]=-6, R[5]=4, R[6]=9, R[7]=0, R[8]=8. Определите значение суммы после выполнения следующего фрагмента программы: sum:=0; for i:=1 to 8 do sum:=sum+r[i]; writeln (sum);

А) 25;  Б) 36;  В) -11;  Г) 21

12. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]=-6, R[5]=4, R[6]=9, R[7]=0, R[8]=8. Определите значение переменной kol после выполнения следующего фрагмента программы: kol:=0; for i:=1 to 8 do if r[i]>-2 then kol:=kol+1; writeln (kol);

А) 7;  Б) 8;  В) 5;  Г) 6

Часть II. Задания достаточного и высокого уровней

1. (1 балл) Какие значения примут элементы массива A[3] и A[4] после выполнения последовательности операторов, если первоначально

  A[3] := 5;  A[4] := 6;

   A[3] = A[4];

   A[4] := A[3]?

2. (1 балл) В представленном фрагменте программы значения одномерного массива задаются с помощью оператора цикла. Чему будет равно A[5]?

For i := 1 To 5 Do

Begin

      A[2*i - 1] := i;

      A[2*i] := i*i;

   End;

3. (2 балла) Пусть имеется массив, заполненный целыми числами. Найдите сумму и среднее арифметическое всех четных элементов массива. Найдите минимальный элементы массива.

4. (2 балла) Постройте двумерный массив d (5´5) по формуле dij = sin(i+j); i =1, 2, …,5; j = 1, 2, …,5.

Выведите массив на экран в виде таблицы, задайте форматы вывода чисел с двумя цифрами после запятой. Отрицательные элементы замените нулями, определите количество положительных элементов.

-80%
Курсы дополнительного образования

Основы HTML

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Сохранить у себя:
Контрольные работы по программированию на языке Pascal (0.05 MB)

Комментарии 3

Чтобы добавить комментарий зарегистрируйтесь или на сайт

Kamil, 27.04.2015 08:58
Privrt
Екатерина Васильева, 07.05.2013 09:07
Как получить ответы на тест?
татьяна, 24.09.2012 21:46
хорошая разработка