Меню
Тесты
Тесты  /  Информатика  /  11 класс  /  Вложенные списки Python

Вложенные списки Python

Avatar
23.01.2023. Тест. Информатика, 11 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Аннотация. Урок посвящен вложенным спискам, то есть спискам, входящим в качестве элементов в другие списки.

Список вопросов теста

Вопрос 1

Что покажет приведенный ниже фрагмент кода?

list1 = [[1, 8, 9], [4, 8, 12, 16], [0, 2, 7]]
print(list1[0][1] + list1[1][2] + list1[2][2])
Варианты ответов
  • 5
  • 13
  • 27
  • IndexError: list index out of range
  • 8
  • 11
Вопрос 2

Что покажет приведенный ниже фрагмент кода?

list1 = [[1, 8, 9], [4, 8, 12, 16], [0, 2, 7]]
print(list1[0][1] + list1[1][2] + list1[2][2])
Варианты ответов
  • 5
  • 13
  • 27
  • IndexError: list index out of range
  • 8
  • 11
Вопрос 3

Что покажет приведенный ниже фрагмент кода?

list1 = ['Beegeek', [4, 8, 12, 16]]
print(list1[0][1])
print(list1[1][3])
Варианты ответов
  • e

    12

  • B

    12

  • e

    16

  • B 8

    e 16

Вопрос 4

Задан список: 

list1 = [[0, [9, 2]], [1, [4, 6, 3], [5, 2, 3], 8, 3]]

Чему равно значение list1[1][2][1]?

Вопрос 5

Задан список: 

list1 = [[1, 2, 3], [4, 5], [8], [1, 2, 3, 4]]

Чему равно значение len(list1)?

Вопрос 6

Задан список: 

list1 = [[[1, 1, 0], [0, 1, 1]], [[0, 1], [1, 1], [1, 0]]]

Чему равно значение len(list1)?

Вопрос 7

Что покажет приведенный ниже фрагмент кода? 

list1 = [[1, 8, 7, 4], [1, 3, 4, 5], [2, 7, 2], [2, 6, 7, 8]]
list1.reverse()
print(list1)
Варианты ответов
  • [[4, 7, 8, 1], [5, 4, 3, 1], [2, 7, 2], [8, 7, 6, 2]]
  • [[2, 6, 7, 8], [2, 7, 2], [1, 3, 4, 5], [1, 8, 7, 4]]
  • [[8, 7, 6, 2], [2, 7, 2], [5, 4, 3, 1], [4, 7, 8, 1]]
  • [[1, 8, 7, 4], [1, 3, 4, 5], [2, 7, 2], [2, 6, 7, 8]]
Вопрос 8

Что покажет приведенный ниже фрагмент кода? 

list1 = [[1, 8, 7, 4], [1, 3, 4, 5, 6], [2, 7, 2], [2, 6, 7, 8]]
print(max(list1))
Варианты ответов
  • [2, 7, 2]
  • [1, 3, 4, 5, 6]
  • [1, 8, 7, 4]
  • [2, 6, 7, 8]
Вопрос 9

Что покажет приведенный ниже фрагмент кода? 

list1 = [[1, 8, 7, 4], [1, 3, 4, 5, 6], [2, 7, 2], [2, 6, 7, 8]]
del list1[1]
print(list1)
Варианты ответов
  • [[1, 3, 4, 5, 6], [2, 7, 2], [2, 6, 7, 8]]
  • [[1, 8, 7, 4], [2, 7, 2], [2, 6, 7, 8]]
  • [[1, 8, 7, 4], [1, 3, 5, 6], [2, 7, 2], [2, 6, 7, 8]]
  • [[1, 8, 7, 4], [1, 4, 5, 6], [2, 7, 2], [2, 6, 7, 8]]
  • [[1, 7, 4], [1, 4, 5, 6], [2, 2], [2, 7, 8]]
Вопрос 10

Что покажет приведенный ниже фрагмент кода? 

list1 = [[1, 8, 7, 4], [1, 3, 4, 5, 6], [2, 7, 2], [2, 6, 7, 8]]
del list1[1][1]
print(list1)
Варианты ответов
  • [[1, 8, 7, 4], [2, 7, 2], [2, 6, 7, 8]]
  • [[1, 3, 4, 5, 6], [2, 7, 2], [2, 6, 7, 8]]
  • [[1, 7, 4], [1, 4, 5, 6], [2, 2], [2, 7, 8]]
  • [[1, 8, 7, 4], [1, 4, 5, 6], [2, 7, 2], [2, 6, 7, 8]]
  • [[1, 8, 7, 4], [1, 3, 5, 6], [2, 7, 2], [2, 6, 7, 8]]
Вопрос 11

Что покажет приведенный ниже фрагмент кода?

list1 = [[1, 2, 3], [4, 5]]
list2 = list1

list1[0].append(7)

print(list2)
Варианты ответов
  • [[1, 2, 3], [4, 5, 7]]
  • [[1, 2, 3, 7], [4, 5]]
  • [[1, 2, 3], [4, 5], [7]]
  • [[1, 2, 3], [4, 5]]
  • [[1, 2, 3], [4, 5], 7]
Вопрос 12

Чему будет равно list1[1][1] после выполнения следующего фрагмента кода:

list1 = [[1] * 3] * 3
list1[0][1] = 5
Вопрос 13

Что покажет приведенный ниже фрагмент кода

n = 3
list1 = []

for _ in range(n):
    row = input().split()
    list1.extend(row)

print(list1)

если на вход программе подаются строки:

9 7 6
2 1
3 4 45 67
Варианты ответов
  • [[9, 7, 6], [2, 1], [3, 4, 45, 67]]
  • ['9', '7', '6', '2', '1', '3', '4', '45', '67']
  • [9, 7, 6, 2, 1, 3, 4, 45, 67]
  • [['9', '7', '6'], ['2', '1'], ['3', '4', '45', '67']]
Вопрос 14

Какой тип данных будет у переменной row?

my_list = [[1], [2, 3], [4, 5, 6]]
total = 0

for row in my_list:
    total += sum(row)

print(total)
Варианты ответов
  • float
  • list
  • int
  • str
  • None
Вопрос 15

Что покажет приведенный ниже фрагмент кода?

my_list = [[12, 221, 3], [41, 5, 633], [71, 8, 99]]

maximum = my_list[0][0]
minimum = my_list[0][0]

for row in my_list:
    maximum = max(row)
    minimum = min(row)

print(maximum + minimum)
Вопрос 16

Что покажет приведенный ниже фрагмент кода?

my_list = [[12, 221, 3], [41, 5, 633], [71, 8, 99]]

maximum = my_list[0][0]
minimum = my_list[0][0]

for row in my_list:
    if max(row) > maximum:
        maximum = max(row)
    if min(row) < minimum:
        minimum = min(row)

print(maximum + minimum)
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт