Тест по теме Начальные сведения о языке Паскаль
Список вопросов теста
Вопрос 1
Разработчиком языка Паскаль является:
Варианты ответов
- Блез Паскаль
- Никлаус Вирт
- Норберт Винер
- Эдсгер В. Дейкстра
Вопрос 2
Что из перечисленного не входит в алфавит языка Паскаль?
Варианты ответов
- русские буквы
- служебные слова
- латинские строчные и прописные буквы
- знак подчёркивания и знаки препинания
Вопрос 3
Переменные целого типа имеют следующий тип данных:
Варианты ответов
- real
- boolean
- integer
- сhar
Вопрос 4
В программе на языке Паскаль обязательно должен быть:
Варианты ответов
- заголовок программы
- блок описания используемых данных
- программный блок
- оператор присваивания
Вопрос 5
Расставьте приведенные строки в такой последовательности, чтобы получился общий вид программы на языке Паскаль. В ответе запишите последовательность букв – обозначений строк.
А var <описание используемых переменных>
Б program <имя программы>
С end.
Д begin <начало программного блока>
Вопрос 6
Какая последовательность символов не может служить именем в языке Паскаль?
Варианты ответов
- _summa
- ПАСКАЛЬ_1
- Bred(12)
- qq2
Вопрос 7
При присваивании изменяется:
Варианты ответов
- имя переменной
- тип переменной
- значение переменной
- значение константы
Вопрос 8
Для вывода информации на экран используется оператор:
Варианты ответов
- begin
- readln
- writeln
Вопрос 9
Описать переменную – это значит указать её
Варианты ответов
- имя, тип и значение
- имя и значение
- тип и значение
- имя и тип
Вопрос 10
Расположите строки так, чтобы получилась программа Summa, рассчитывающая по двум введенным с клавиатуры числам их сумму. В ответе запишите правильную последовательность номеров без пробелов.
1. program Summa;
2. S:=A+B;
3. write (‘Сумма равна’, S)
4. var A, B, S: integer;
5. begin
6. read (A, B);
7. write (‘Введите два числа: ‘);
8. end.