Меню
Тесты
Тесты  /  Информатика  /  11 класс  /  Структурированные типы данных. Массивы . Структурное программирование.

Структурированные типы данных. Массивы . Структурное программирование.

Avatar
08.02.2022. Тест. Информатика, 11 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
§ 8. Структурированные типы данных. Массивы. § 9. Структурное программирование.

Список вопросов теста

Вопрос 1

 

Что такое массив? 

Варианты ответов
  • это простой тип данных, состоящий из одного элемента
  • это совокупность данных, объединенных под одним именем
  • это структурированный тип данных, состоящий из элементов разных типов
  • это структурированный тип данных, состоящий из элементов одного типа, упорядоченных по номеру и объединенных одним именем
Вопрос 2

 

Все  переменные, входящие в массив, имеют одно и тоже имя, а различаются по _____________ в массиве. (Вставь слово)

Вопрос 3

 

Описание массива выглядит так: 

var day: array [1..7] of integer;

Укажите имя структуры.

Вопрос 4

Программист написал программу:

program prim1;
const n=5;
var а:array [1..n] of integer; m,i: integer;
begin
m:=0;
for i:=1 to n do
  begin
      read(a[i]);
      if a[i]<0 then m:=m+a[i];
  end;
writeln("m=",m);
end.

Какого типы элементы массива?

Вопрос 5

Программист написал программу:

program prim1;
const n=5;
var а:array [1..n] of integer; m,i: integer;
begin
m:=0;
for i:=1 to n do
  begin
      read(a[i]);
      if a[i]<0 then m:=m+a[i];
  end;
writeln("m=",m);
end.

Сколько элементов в массиве?

 

Варианты ответов
  • 5
  • 6
  • 4
Вопрос 6

Программист написал программу:

program prim1;
const n=5;
var а:array [1..n] of integer; m,i: integer;
begin
m:=0;
for i:=1 to n do
  begin
      read(a[i]);
      if a[i]<0 then m:=m+a[i];
  end;
writeln("m=",m);
end.

Сумму каких элементов находит программа?

Вопрос 7

Программист написал программу:

program prim1;
const n=5;
var а:array [1..n] of integer; m,i: integer;
begin
m:=0;
for i:=1 to n do
  begin
      read(a[i]);
      if a[i]<0 then m:=m+a[i];
  end;
writeln("m=",m);
end.

Чему равен результат программы, если a[1]=2, a[2]=-4, a[3]=5, a[4]=-5, a[5]=3.

Вопрос 8

 

Обращение к элементу массива осуществляется по: 

Варианты ответов
  • индексу
  • нет верных ответов
  • имени массива
  • имени массива и индексу
Вопрос 9

 

Описание массива производится для того, чтобы: 

Варианты ответов
  • человек помнил количество ячеек в массиве
  • компьютер составил алгоритм для обработки массива
  • компьютер зарезервировал память для хранения элементов массива
  • компьютер запомнил имя массива
Вопрос 10

Какими способами можно заполнить массив?

Варианты ответов
  • все варианты
  • случайным образом
  • ввод с клавиатуры
  • по формуле
Вопрос 11

 

Что такое индекс в одномерном массиве? 

Варианты ответов
  • порядковый номер элемента массива
  • имя массива
  • размерность массива
  • наибольший размер элемента массива
Вопрос 12

 

Для заполнения массива путем ввода чисел с клавиатуры мы используем оператор: 

Варианты ответов
  • write
  • read
  • until
  • readln
  • random
  • randomize
  • writeln
Вопрос 13

 

Что производит следующий фрагмент программы?

for i:=1 to n do writeln(a[i]);

Варианты ответов
  • Ввод элементов массива с клавиатуры. .
  • Ввод элементов массива из файла
  • Вывод элементов массива на экран монитора в столбец
  • Вывод элементов массива на экран монитора в строку.
Вопрос 14

 

Имеется описание: 

var c:array[0..20] of integer; 

Для хранения массива с будет отведено ... ячеек.

Варианты ответов
  • 21
  • 38
  • 40
  • 19
  • 20
Вопрос 15

 

Чему равна сумма значений элементов массива a[1] и a[4],  сформированного следующим образом? 

for i:=1 to 5 do a[i]:=i*(i+1)

Варианты ответов
  • 6
  • 2
  • 12
  • 42
  • 22
  • 30
Вопрос 16

 

Массив описан следующим образом:

b:array[1..5] of integer=(0, 2, 3, 5, 11); 

Значение выражения    b[5]*b[4] - b[2] - b[3]*b[1]   равно.

Вопрос 17

Что такое рекурсия?

Варианты ответов
  • функция, которая вызывает другую функцию
  • функция, которая вызывается сама по себе
  • функция, которая вызывает другую процедуру
  • функция, которая вызывает саму себя
Вопрос 18

Выберите верные утверждения.

 

 

Варианты ответов
  • Функция может иметь несколько значений, а процедура только одно (оно и будет ее результатом).
  • Процедура может иметь несколько значений, а функция только одно (оно и будет ее результатом)
  • Процедура и функция -это подпрограммы имеющие имя.
  • Процедура может иметь только одно значение, как и функция.
  • Процедура и функция вызываются по ключевому слову.
  • Процедура имеет параметры-значения и праметр -переменую.
Вопрос 19

Как избавиться от бесконечного обращения подпрограммы к самой себе?

Варианты ответов
  • Требуется наличие некоторого условия (условного оператора) в тексте программы, по достижении которого дальнейшее обращение не происходит.
  • Требуется наличие оператора цикла в тексте программы, по окончании которого дальнейшее обращение не происходит.
Вопрос 20

Что такое подпрограмма?

Варианты ответов
  • Подпрограмма – это независимая от основной программы группа операторов, оформленная в виде самостоятельной программной единицы. Она записывается однократно, обращение к ней из основной программы не происходит.
  • Подпрограмма – это повторяющаяся группа операторов, оформленная в виде самостоятельной программной единицы. Она записывается однократно, а в соответствующих местах программы обеспечивается лишь обращение к ней по имени.
  • Подпрограмма – это повторяющаяся группа операторов, оформленная в виде самостоятельной программной единицы и записанная в отдельный файл.
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт