Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  Строки в Паскале

Строки в Паскале

Avatar
21.04.2020. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Функции и процедуры для работы со строковыми переменными

Список вопросов теста

Вопрос 1

Что будет выведено на экран после выполнения программы?

  s := '123';
  s := s + '0' + s;
  s := s + s;
  writeln ( s );

Вопрос 2

Что будет выведено на экран после выполнения этой программы?

  s := '123';
  s := s + s[2] + s + s[3];
  writeln ( s );

Вопрос 3

Что будет выведено на экран после выполнения этой программы?

  s := '12345';
  n := Length(s) + Length('456');
  writeln ( n );

Вопрос 4

Что будет выведено на экран после выполнения программы?

  s := '123456789';
  s1 := 'abcdef';
  s := Copy(s,5,2) + '0' + Copy(s1,3,3);
  writeln ( s );

Вопрос 5

Что будет выведено на экран после выполнения этой программы?

  s := '123456';
  q := 'abc';
  Delete ( s, 2, 3 );
  Insert ( s, q, 2 );
  writeln ( q );

Вопрос 6

Что будет выведено на экран после окончания работы программы?

  s := '123456789';
  Delete ( s, 1, 2 );
  n := Pos ( '6', s );
  writeln ( n );

Вопрос 7

Что будет выведено на экран после выполнения этой программы?

  s := '123456789';
  n := Pos ( '456', s);
  Delete ( s, n+2, 3 );
  writeln ( s );

Вопрос 8

Сколько единиц будет выведено на экран?

  s := '123456';
  while Length(s) > 0 do begin
    Delete ( s, 1, 2 );
    writeln ( '1' )
  end;

Вопрос 9

Программа должна считать, сколько раз в строке S встречается цифра '0'. Какой оператор надо вставить вместо многоточия? Вводите ответ без пробелов.

  c := 0;
  for k:=1 to Length(S) do begin
    if S[k] = '0' then
      ...
  end;

Вопрос 10

Какой оператор надо вставить вместо многоточия, чтобы в строке S были записаны символы строки Q в обратном порядке? Вводите ответ без пробелов.

  Q := '123456789';
  S := '1';
  for k:=2 to 9 do begin
    ...
  end;

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт