Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  Самостоятельная работа "Массивы"

Самостоятельная работа "Массивы"

Avatar
21.05.2024. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Самостоятельная работа по теме "Массивы" (текущий контроль)

Список вопросов теста

Вопрос 1

В записи Q[5][6]=10
6 обозначает

 
Варианты ответов
  • индекс строки массива
  • индекс столбца массива
  • имя массива
  • значение элемента массива
Вопрос 2

В записи Q[5][6]=10
5 обозначает

 
Варианты ответов
  • индекс строки массива
  • индекс столбца массива
  • имя массива
  • значение элемента массива
Вопрос 3

В записи Q[5][6]=10
Q обозначает

 
Варианты ответов
  • индекс строки массива
  • индекс столбца массива
  • имя массива
  • значение элемента массива
Вопрос 4

В записи Q[5][6]=10
10 обозначает

 
Варианты ответов
  • индекс строки массива
  • индекс столбца массива
  • имя массива
  • значение элемента массива
Вопрос 5

Для массива  [7, 10, 8, 3, 1, 7]

определите, какое значение будет выведено:

sum = 0

for i in range(N):

  if A[i] % 2 != 0:

    sum += A[i] 

print( sum )

Вопрос 6

Выберите правильное заполнение целочисленного массива  m из 10 элементов, вводом значений с клавиатуры

 
Варианты ответов
  • for i in range(10): m[i]=input()
  • for i in range(10): m[i]=float(input())
  • for i in range(10): m[i]=int(input())
  • for i in range(n): m[i]=int(input())
Вопрос 7

Дан массив a = [12, 7, 15, 10, 3, 58, 8, 25, 19, 17]
Что выполнит фрагмент программы:
for i in range(10):
    if a[i]%2==0:
        print(a[i])

 
Варианты ответов
  • выведет все четные элементы массива
  • выведет все нечетные элементы массива
  • выведет все положительные элементы массива
  • выведет количество четных элементов
  • выведет все отрицательные элементы массива
Вопрос 8

Дан массив a = [12, 7, 15, 10, 3, 58, 8, 25, 19, 17]
Что выведет данный фрагмент программы:
for i in range(10):
    if i%2!=0:
        print(a[i])

 
Вопрос 9

Для массива  [5, 2, 8, 3, 1, 7] определите разность нулевого и третьего элемента

Вопрос 10

Для массива  [15, 2, 8, 7, 21, 7] определите произведение A[1] и A[4]

Вопрос 11

Чему равна сумма элементов массива

n = 3
A = [[0] * n for i in range(n)]
    for i in range(n):
       for j in range(n):
          if i > j:
              A[i][j] = 0
          else:
              A[i][j] = 1

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт