Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  (Python) Условный оператор и циклы (2 вариант)

(Python) Условный оператор и циклы (2 вариант)

Avatar
02.02.2023. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Различные формы условного оператора. Цикл со счетчиком - for. Оператор цикла с условием - WHILE.

Список вопросов теста

Вопрос 1

Определите значение переменной «a» после выполнения фрагмента программы:

  a = 10
  if a > 5:  
      a = 12
Вопрос 2

Определите значение переменной «a» после выполнения фрагмента программы:

  a = 10
  if a < 15:
      a += 12
  else:
      a -= 7
Вопрос 3

Определите значение переменной «a» после выполнения фрагмента программы:

  a = 10
  if a < 5: a += 12
  else:     a -= 7
  if a < 5: a += 12
  else:     a -= 7
Вопрос 4

 Определите значение переменной «a» после выполнения фрагмента программы:

  a = 10
  b = 3
  if a > b: b += 12
  else:     a -= 7
  if a > b: a += 12
  else:     b -= 7
Вопрос 5

Определите значение переменной «a» после выполнения фрагмента программы:

  a = 10
  b = 5
  if a > 1  and  a < b: 
      a -= 5
  if a > 1  and  a == b: 
      a -= 5
Вопрос 6

Какую логическую операцию нужно добавить в программу вместо многоточия, чтобы значение переменной «a» после выполнения фрагмента программы стало равно 17?

  a = 10
  b = 5
  if a > 1  ...  a < b: 
      a -= 7
  else:
      a += 7
Вопрос 7

Какое число будет выведено на экран в результате выполнения этого цикла?

  i = 3
  print ( "9", end="" )
  while i < 6:
      print ( i, end="" ) 
      i += 1
Вопрос 8

Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?

  i = 3
  while i >= ...:
      print ( "Привет!" )
      i -= 1
Вопрос 9

Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?

  i = ...
  while i <= 2:
      print ( "Привет!" )
      i += 1
Вопрос 10

Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?

  a = 10;
  for i in range(2):
      a -= 1
Вопрос 11

Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?

  a = 4
  for i in range(4):
       a += a
Вопрос 12

Какое число будет выведено на экран после выполнения этого фрагмента программы?

  for i in range(3,-1,-1):
       print ( i, end="" )
Вопрос 13
 Какое число будет выведено на экран после выполнения этого фрагмента программы?
  print ( 1, end="" )
  for i in range(3,6):
      print ( i, end="" )
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт