Меню
Тесты

Python

Avatar
14.05.2020. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Работа содержит 41 задание, время выполнения составляет 40 минут

Список вопросов теста

Вопрос 1

Какие из приведённых утверждений являются ложными?

Варианты ответов
  • Программы на Python состоят из модулей
  • Переменные в Python автоматически объявляются перед первым использованием
  • Python не является интерпретируемым языком программирования
  • Переменная - это именованная область жёсткого диска
Вопрос 2

Какие значения из указанных могут принимать переменные типа int?

Варианты ответов
  • 10
  • 7.8
  • -10
  • 'a10c'
Вопрос 3

Запишите инструкцию для определения типа переменной a. Ответ запишите без пробелов.

Вопрос 4

Как в языке Python называются указания компьютеру, определяющие, какие операции выполнит компьютер над данными?

Варианты ответов
  • Модули
  • Операторы
  • Инструкции
  • Команды
Вопрос 5

Какая символьная строка будет сформирована при выполнении инструкции

s = '{:5.2f}'.format (3.1496)?

При записи ответа вместо пробелов используйте нижние подчёркивания.

Вопрос 6

Что будет выведено на экран в результате выполнения инструкции

print (2, 'a', 8, sep = ', ')?

Вопрос 7

Выберите инструкцию, присваивающую переменной a значение, введённое пользователем с клавиатуры.

Варианты ответов
  • print (a)
  • input (a)
  • a = input ()
  • a = print ()
Вопрос 8

Установите соответствие между функциями и их значениями, если x = 1.69

1.

1

2.

1.69

3.

1.3

4.

2

Варианты ответов
  • sqrt (x)
  • abs (x)
  • int (x)
  • round (x)
Вопрос 9

Запишите результат операции -9 // 5

Вопрос 10

Как называются алгоритмы, в которых команды выполняются последовательно в том порядке, в котором они записаны?

Варианты ответов
  • Рекурсивные
  • Линейные
  • Разветвляющиеся
  • Циклические
Вопрос 11

Установите соответствие между названиями логических операций и их обозначениями в языке Python.

1.

or     

2.

not

3.

and

Варианты ответов
  • Конъюнкция
  • Дизъюнкция
  • Инверсия
Вопрос 12

При помощи чего простые логические высказывания соединяются в сложные?

Варианты ответов
  • С помощью основных арифметических операций
  • С помощью инструкции присваивания
  • С помощью логических операций
  • С помощью союзов
Вопрос 13

Как называется алгоритмическая конструкция, которая в зависимости от некоторого условия исполняет одну из двух последовательностей действий?

Варианты ответов
  • Цикл
  • Рекурсия
  • Следование
  • Ветвление
Вопрос 14

Какое значение, должна иметь переменная s, чтобы в ветвлении с условием s != 0 выполнился блок else?

Запишите число.

Вопрос 15

Что произойдёт при попытке исполнения инструкций?

import random

k = random.random ()

while k < 1:

       t = random.randint (100, 200)

Варианты ответов
  • Ничего из выше перечисленного
  • Программа завершится с сообщением об ошибке
  • Произойдёт зацикливание программы
  • Цикл ни разу не будет выполнен
Вопрос 16

Из перечисленных слов выберите инструкции управления циклом в языке Python.

Варианты ответов
  • pass
  • else
  • break
  • continue
Вопрос 17

Какое будет значение i после исполнения инструкций?

i, n = 0, 625

while n > 0:

    n = n // 5

    i = i +1

Вопрос 18

Установите соответствие между инструкциями управления циклом и их описанием.

1.

continue

2.

break

3.

else

Варианты ответов
  • Начинает описание блока, который будет выполнен, если условие цикла изначально ложно
  • Завершает работу цикла
  • Завершает текущее исполнение тела цикла
Вопрос 19

Чему будет равно значение переменной а после исполнения инструкций?

import random

a, i = 0, random.randint (-10, 10)

t = i > 0:

while t and not t:

      a = a + 5 ** 2

Вопрос 20

Чему будет равно значение a после исполнения инструкций?

def f (a):

  s = 0

  while a > 0:

        s, a = s + a % 10, a // 10

  return s

a = f (248)

Вопрос 21

Запишите служебное слово, с которого начинается описание функции на языке Python.

Вопрос 22

Какие из утверждений правдивы?

Варианты ответов
  • Из внешней программы нельзя обращаться к параметрам функции
  • У функции обязательно должны быть входные параметры
  • При вызове функции количество и порядок следования входных параметров должны соответствовать указанным в описании
  • Функция всегда возвращает произвольное количество параметров
  • При вызове функции имена её параметров не должны соответствовать указанным в описании
Вопрос 23

Как называется вспомогательный алгоритм, который напрямую или через другие вспомогательные алгоритмы вызывает сам себя?

Варианты ответов
  • Линейный
  • Циклический
  • Разветвляющийся
  • Рекурсивный
Вопрос 24

Чему будет равно а после исполнения инструкций?

def func (num):

      if num < 10:

           return num

      else:

           return func (num % 10 + num % 100 // 10)

a = func (275)

Вопрос 25

Из каких частей состоит рекурсивное определение?

Варианты ответов
  • Базовые случаи
  • Инверсная часть
  • Индуктивная часть
  • Противоречащие случаи
Вопрос 26

Выберите ложные утверждения.

Варианты ответов
  • Программный стек не ограничен
  • Рекурсивные алгоритмы обязательно должны содержать вызов самого себя или другого вспомогательного алгоритма
  • Рекурсивные алгоритмы работают быстрее итерационных
  • Рекурсивные алгоритмы обычно короче и понятнее итерационных
Вопрос 27

Через пробел запишите числа, которые будут в списке?

a = [i for i in range (10) if i % 2 == 0]

Вопрос 28

Какие из утверждений правдивы?

Варианты ответов
  • Элементы списка содержат ссылки на области оперативной памяти
  • Длина списка может только увеличиваться
  • Список - это динамическая структура
  • Значения элементов списка постоянны
Вопрос 29

Без пробелов запишите инструкцию вывода на экран среднего арифметического элементов списка а?

Вопрос 30

Как называется набор элементов, каждый из которых имеет свой уникальный идентификационный номер?

Варианты ответов
  • Файл
  • Текст
  • Массив
  • Список
Вопрос 31

Как с помощью стандартной функции сортировки языка Python получить список B состоящий из элементов списка А, отсортированных по возрастанию?

Варианты ответов
  • B = sorted (A, reverse = True)
  • A = sorted (B)
  • B = sorted (A, reverse = False)
  • B = sorted (A)
Вопрос 32

К какому типу алгоритмов относится быстрая сортировка элементов списка?

Варианты ответов
  • К рекурсивным
  • К разветвляющимся
  • К циклическим
  • К линейным
Вопрос 33

Что будет выведено на экран при исполнении инструкций?

s, t = 'Владикавказ', 'Владивосток'

if t > s:

    print (s)

else:

    print (t)

Вопрос 34

Как называется прямоугольная таблица из элементов одного типа?

Варианты ответов
  • Массив
  • Матрица
  • Символьная строка
  • Список
Вопрос 35

В какой из инструкций допущена ошибка, если s = 'мама мыла раму'?

Варианты ответов
  • s = s[0:4]
  • t = s[3]
  • s[3] = ' '
  • t = s[0:4]
Вопрос 36

Установите соответствие между режимами открытия файла и тем, как они записываются на языке Python.

1.

w

2.

r

3.

a

Варианты ответов
  • Для чтения
  • Для добавления данных
  • Для записи
Вопрос 37

Выберите ложные утверждения.

Варианты ответов
  • В программах на языке Python нельзя описать обработку исключений
  • С точки зрения программиста все файлы можно разделить на текстовые, двоичные и графические
  • Программа завершает своё исполнение ошибкой, если в ней возникло необрабатываемое исключение
  • При программировании файлы представляются через файловые переменные
Вопрос 38

Запишите инструкцию для открытия в переменной f файла input.txt для чтения. Ответ запишите без пробелов.

Вопрос 39

Как называется любая ошибка, возникшая в ходе исполнения программы?

Варианты ответов
  • Исключение
  • Помарка
  • Баг
  • Жучок
Вопрос 40

Установите верный порядок следования этапов обработки файла при программировании.

Варианты ответов
  • Открытие файла
  • Ввод/вывод данных
  • Закрытие файла
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт