Pascal - начало
Список вопросов теста
Вопрос 1
Выберите служебное слово, с которого начинается раздел описания типов переменных
Варианты ответов
- begin
- var
- integer
- real
- writeln
Вопрос 2
Выберите строку программы, которая выводит на экран компьютера значение переменной a
Варианты ответов
- var a: integer;
- readln ('y = ', a);
- readln (a);
- writeln ('y = ', a);
- writeln ('a = ', y)
Вопрос 3
Выберите строку программы, которая считывает с клавиатуры компьютера введённое значение и присваивает его переменной a
Варианты ответов
- var a: integer;
- readln ('y = ', a);
- readln (a);
- writeln ('y = ', a);
- writeln ('a = ', y)
Вопрос 4
Укажите типы (структуры) алгоритмов.
Варианты ответов
- Линейный (следование)
- Циклический (повторение)
- Графический (блок-схема)
- Разветвляющийся (ветвление)
- Программирование (паскаль)
Вопрос 5
Раздел объявления типов переменных имеет следующий вид:
Var b, k:integer; c: real;
Укажите правильные строки программы.
Варианты ответов
- b := 25;
- k := b / 2;
- k := b + 7;
- c := b / 2;
- b := k + c;
Вопрос 6
Определите значение переменной с после выполнения следующего фрагмента программы:
a := 4;
a := a + 6;
b := a - 15;
c := a + b;
Вопрос 7
Укажите типы переменных
Варианты ответов
- integer
- var
- real
- string
- readln
Вопрос 8
Определите значение переменных a и b после выполнения следующего фрагмента программы:
a := 4;
b := a + 5;
a := b;
b := a;
В ответе запишите два числа через один пробел, например: 6 12
Вопрос 9
Для данного фрагмента программы
x := 20;
y := x / 2;
z := x + y;
p := 'Осенние каникулы';
s := x * 2;
подберите верное описание переменных
Варианты ответов
- var y, z : integer; x, s : real; p : string;
- var y, z : string; x, s : integer; p : real;
- var y : real; x, z, s : integer; p : string;
- var x, y, z, s : integer; p : string;
- var y, z : real; x, s : integer; p : string;
Вопрос 10
Определите значение пременной x ? x := (20 mod 3) - 2


