Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Язык программирования Pascal. Основные сведения и операторы

Язык программирования Pascal. Основные сведения и операторы

Avatar
30.03.2020. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тест для проверки знаний по теме "Основные сведения о языке программирования Pascal"

Список вопросов теста

Вопрос 1

Какие имена допустимы в языке программирования Pascal?

Варианты ответов
  • R
  • r1
  • soprot
  • 1R
  • сопрот
Вопрос 2

Какие имена недопустимы в языке программирования Pascal?

Варианты ответов
  • massa
  • m2
  • 2m
  • massa tela
  • масса_тела
Вопрос 3

Установите соответствие между служебными словами языка программирования Pascal и их назначением:

1.

var

2.

read

3.

write

4.

begin

5.

end

Варианты ответов
  • раздел описания переменных
  • ввод данных в программу
  • вывод данных на экран
  • начало программного блока
  • конец программного блока
Вопрос 4

Установите соответствие между названиями типов данных и их обозначениями в языке программирования Pascal:

1.

integer

2.

real

3.

char

4.

string

Варианты ответов
  • целочисленный
  • вещественный
  • символьный
  • строковый
Вопрос 5

Установите соответствие между типами величин и их значениями:

1.

5

2.

5.1

3.

'А'

4.

'АБВГД'

Варианты ответов
  • integer
  • real
  • char
  • string
Вопрос 6

Какая запись раздела описания переменных a, b, c, d является верной, если этим переменным могут быть присвоены значения 3, '3', 3.3, '3.3' соответственно?

Варианты ответов
  • var a:integer; b:char; c:real; d:string;
  • var a:real; b:char; c:integer; d:string;
  • var a:char; b:string; c:integer; d:real;
  • var a:integer; b:string; c:real; d:char;
  • var a:integer; b:char; c:string; d:real;
Вопрос 7

Установите соответствие между операторами и результатами их выполнения, если значение переменной равно 5:

1.

write (a);

2.

write ('a');

3.

write ('a=', a);

4.

write (a:5:1);

Варианты ответов
  • 5
  • a
  • a=5
  • __5.0
Вопрос 8

Установите соответствие между операторами ввода и введенными данными, если целочисленные переменные a, b, c должны получить значения 10, 20, 30 соответственно.

1.

read (b, c, a)

2.

read (b, a, c)

3.

read (c, a, b)

4.

read (c, b, a)

Варианты ответов
  • 20 30 10
  • 20 10 30
  • 30 10 20
  • 30 20 10
Вопрос 9

Выберите выражение, записанное на языке программирования Pascal, соответствующее математической записи, представленной на рисунке:

Варианты ответов
  • (a+b/c+d)
  • (a+b)/c+d
  • (a+b/c)+d
  • (a+b)/(c+d)
  • a+b/(c+d)
Вопрос 10

Выберите выражение, записанное на языке программирования Pascal, соответствующее математической записи, представленной на рисунке:

Варианты ответов
  • 1/2(a+b)h
  • 1/2*(a+b)/h
  • 1/2/(a+b)/h
  • (a+b)*h/2
  • (a+b)*2/h
Вопрос 11

Какие выражения на языке программирования Pascal не соответствуют математическому выражению, представленному на рисунке?

Варианты ответов
  • (-b+sqrt(b*b-4*a*c))/(2*a)
  • (-b+sqrt(b*b-4*a*c))/2*a
  • (-b+sqrt(b*b-4*a*c))/2/a
  • -b+sqrt(b*b-4*a*c)/(2*a)
  • (sqrt(b*b-4*a*c)-b)/(2*a)
Вопрос 12

Чему будет равно значение переменной b после выполнения данного фрагмента программы?

a := 20;
b := 40;
b := a + b;
a := b - a;
b := b + a;

Вопрос 13

Чему будет равно значение переменной a после выполнения данного фрагмента программы?

a := 85;
b := 7;
a := a div b;
b := a mod b;
a := a + b;

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт