Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Описание, заполнение и вывод массива

Описание, заполнение и вывод массива

Avatar
08.12.2020. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Будьте внимательны! На тест отводится 10 минут!

Список вопросов теста

Вопрос 1

Описание одномерного целочисленного массива:

Варианты ответов
  • var a: array[1..5] of integer;
  • var a: array[1..5] of real;
  • var a: array[1...5] of integer;
  • соnst a: array[1..3] of real=(1.1, 1.2, 0.5);
Вопрос 2

Фрагмент программы заполнения целочисленного массива А десятью случайными числами из интервала [0,10]

Варианты ответов
  • for i:=1 to 10 do a[i]:=random(10)
  • for i:=1 to 10 do a[i]:=random(11)
  • for i:=1 to 10 do a[i]:=random(9)+1
  • for i:=1 to 10 do a[i]:=random(11)-1
Вопрос 3

Описание одномерного целочисленного массива c заранее заданными значениями:

Варианты ответов
  • var a: array[1..5] of integer;
  • var a: array[1..5] of real;
  • var a: array[1...5] of integer;
  • соnst a: array[1..3] of integer=(1, 1, 5);
Вопрос 4

Числовой одномерный массив А заполнен последовательно цифрами 2, 5, 7, 34.
Укажите значение элемента А [3].

В ответе укажите только число.

 

Вопрос 5

Запишите значения элементов массива через пробел, сформированного следующим образом:

 for i:=1 to 3 do  a[i]:=2*i

Вопрос 6

Проанализируйте программу:

program  n_2 ;
  var i: integer;
        a: array[1..4] of integer;
begin
        for i:=1 to 4 do a[i]:=i+1;
        for i:=1 to 4 do write (a[i], '  ');
end.

Что будет выведено в результате выполнения программы?

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт