Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Общие сведения о языке программирования Python 8 класс 2 вариант

Общие сведения о языке программирования Python 8 класс 2 вариант

Avatar
05.05.2024. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Промежуточный тест по теме состоит из 21 вопроса. Время выполнения 30 минут

Список вопросов теста

Вопрос 1

Языковые конструкции, с помощью которых в программах записываются действия, выполняемые в процессе решения задачи. называются:

Варианты ответов
  • операндами
  • операторами
  • выражениями
  • данными
Вопрос 2

Укажите ложное высказывание:

Варианты ответов
  • Разделителями между операторами в одной строке служит точка
  • Переменная в Python создается при первом присваивании
  • При присваивании изменяется значение переменной
Вопрос 3

Какие из следующих последовательностей символов можно считать операторами присваивания?
(укажите все верные ответы)

Варианты ответов
  • a += b
  • a = b = 10
  • c = 2c
  • 2a = a + 5
  • d = 25
Вопрос 4

Алфавит языка - это ...

Укажите все верные ответы

Варианты ответов
  • набор допустимых символов, которые можно использовать для записи программы.
  • все буквы русского алфавита
  • любые символы формальных языков
  • неделимые элементы, например, >= (знак больше или равно) и др.
  • утроенные двойные или одинарные кавычки
Вопрос 5

Соотнесите служебные слова языка Python с их значениями

1.

Пока

2.

Или

3.

Вещественный тип

4.

Печать

5.

Истина

Варианты ответов
  • while
  • or
  • print
  • float
  • True
Вопрос 6

Соотнесите знак операции с его значение

1.

остаток от деления

2.

целочисленное деление

3.

знак "не равно"

4.

знак больше или равно

5.

оператор сравнения

6.

возведение в степень

Варианты ответов
  • %
  • //
  • !=
  • >=
  • ==
  • **
Вопрос 7

На экран выводятся значения двух чисел (a и b) с текстовым пояснением.

Выберете  все верные ответы. в которых выведется нужный фрагмент программы.

Варианты ответов
  • print ('a, b')
  • print ('a=' , a, 'b =', b)
  • Print ('a= , a', 'b =, b')
  • print (f 'a={a}, b ={b}')
Вопрос 8

Какое значение будет выведено после выполнения программы,
еcли будут введены  числа 9 и 2 соответственно

а = inрut ()
b = inрut()
sum = а + b
print(sum)

Варианты ответов
  • 92
  • 18
  • 18.0
Вопрос 9

Расположите строки так, чтобы получилась программа, рассчитывающая стоимость покупки по двум введенным с клавиатуры  числам 

А - цена за 1 штуку
В - количество штук .

В ответе запишите правильную последовательность номеров.

Варианты ответов
  • print ("Введите цену и количество)
  • А = float(input())
  • B = int(input())
  • S = A * B
  • print ("Стоимость покупки =", S)
Вопрос 10

Дан фрагмент программы:
а, b = mар(int, inрut() .sрlit ())
с = 0
if а > 0:
    if b > 0:
        с = 3
else : с = 0

Определите значение переменной c при следующих значениях a и b: 2   -3

Ответ запишите в виде числа (например, 4)

Вопрос 11

Дан условный оператор:
if а < 8:
    с = 1
elif а > 8:
    с = 2
else: с = 12

Какое значение имеет переменная а, если в результате выполнения условного оператора переменной с присваивается значение 12? (Запишите в ответе только число)

Вопрос 12

Определите значения переменных s  после выполнения фрагмента программы.

s = 0
i = 2
whilе i < 6:
    i += 1
s = s + i

Ответ запишите в строку в виде числа

Вопрос 13

Определите значение переменной s после выполнения фрагмента программы если а = 123. (подсказка равна 1 баллу)

р = а
s = 0
while True:
   s = s + р % 10
   р = р // 10
   if р == 0: break
priпt (s)

Варианты ответов
  • 123
  • 6
  • 321
  • 0
Вопрос 14

Найдите значение переменной s после выполнения программы

s = 0
for х in rапge (5, 7) :
     s += 1

В ответе напишите только одно число

Вопрос 15

Найдите значение переменной s после выполнения программы

s = 0
for х iп rаnge (5, 7) :
     s += х

В ответе введите только одно число

Вопрос 16

Определите, что будет выведено в результате работы следующей программы. 

а = 2
b = 3
fоr i in rаngе (5, 7) :
    а = а + 3 + а // 3
    b = b + a - b // 4
priпt (а + b)

Варианты ответов
  • 24
  • 42
  • 31
  • 51
Вопрос 17

Определите значение переменной с после выполнения следующего фрагмента программы.
а = 60
b = 10
а = а - b * 4
if а > b:
    с = а - b
еlsе:
   с = b - а

Варианты ответов
  • 200
  • -10
  • 10
  • -190
Вопрос 18

Условный оператор
if  а % 2 == 0:
   priпt ('Да')
еlse:
   priпt ('Нет')

позволяет определить, является ли число а:

Варианты ответов
  • нечётным
  • чётным
  • двузначным
  • простым
  • целым
Вопрос 19

Тело цикла в фрагменте программы
а = 3
b = 4
whilе а + b >= 8:
   а. += 1
   b +=  2

выполнится

Варианты ответов
  • 0 раз
  • 1 раз
  • 2 раза
  • бесконечное число раз
Вопрос 20

Определите значения переменных s и i после выполнения фрагмента программы.
s = 0
i = 8
whilе i > 0:
   s +=  i
   i = i - 2
print ("s=",s, 'i=',i)

Варианты ответов
  • s = 18; i = 0
  • s = 18; i = -2
  • s = 20; i = 0
  • s = 20; i = -2
Вопрос 21

В данном фрагменте программы
s = 0
fоr i iп rапge (0, 17, 2) :
     s = s + 2 * i

вычисляется:

Варианты ответов
  • сумма целых чисел от 0 до 16
  • сумма чётных чисел от 0 до 16
  • сумма нечётных чисел от 0 до 16
  • удвоенная сумма целых чисел от 0 до 16
  • удвоенная сумма чётных чисел от 0 до 16
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт