Обработка массива в Паскале
Список вопросов теста
Вопрос 1
Какая команда пропущена в данном участке программы, отвечающем за поиск номера максимального элемента массива. Запишите команду без пробелов.
r:=1;
for i:=2 to n do
if a[i]>a[r]
then ...
Вопрос 2
Установите верный порядок следования команд при поиске в массиве из 50 элементов, количество элементов равных n
Варианты ответов
- n:=0;
- for i:=1 to 50 do
- if a[i]=k then
- n:=n+1;
Вопрос 3
Отметьте правильное утверждение о массивах в языке Паскаль
Варианты ответов
- элементы массива могут быть разных типов
- все элементы массива должны быть одного типа
- элементы всегда нумеруются с единицы
Вопрос 4
Требуется заполнить массив именно так:
X = [1 3 5 7 9 11]
Какой оператор надо поместить в тело цикла вместо многоточия?
for k:=1 to 6 do begin
...
end;
Варианты ответов
- X[k] := k
- X[k] := 2*k
- X[k] := 2*k - 1
- X[k] := 2*k + 1
Вопрос 5
Для заданного массива N запишите без пробелов команду присваивания элементу с индексом 3 значение суммы элементов с индексами 7 и 4.
Вопрос 6
Что производит следующий фрагмент программы?
For i:=1 to 8 do writeln (a[i]);
Варианты ответов
- Ввод элементов массива по формуле
- Ввод элементов массива с клавиатуры
- Вывод элементов массива в столбец
- Вывод элементов массива в строку
Вопрос 7
Что выполняет фрагмент программы?
For i:=1 to 10 do readln(A[i]);
Варианты ответов
- Ввод элементов массива по формуле
- Ввод элементов массива с клавиатуры
- Вывод элементов массива в столбец
- Вывод элементов массива в строку
Вопрос 8
Что выполняет фрагмент программы?
For i:=1 to 10 do A[i]:=random(1000)-500;
Варианты ответов
- заполнение массива с клавиатуры
- выводит элементы массива на экран
- заполнение массива с помощью датчика случайных чисел
- обнуляет элементы массива
Вопрос 9
Что выполняет фрагмент программы?
For i:=1 to 10 do A[i]:=0;
Варианты ответов
- заполнение массива с клавиатуры
- выводит элементы массива на экран
- заполнение массива с помощью датчика случайных чисел
- обнуляет элементы массива
Вопрос 10
Какое количество данных может находиться в данном массиве?
var А: array[6..18] of integer;
В ответе укажите только число
Вопрос 11
В какой строке НЕ правильное описание массива?
Выберите один или несколько вариантов ответа
Варианты ответов
- var ch: array[1..10] of integer;
- var STL23: array[2..108] of real;
- var stih: array[1,5..7] of real;
- var S: array[1...50] of real;
Вопрос 12
Для подсчета количества положительных элементов массива будем использовать оператор…
Варианты ответов
- If a[i]>0 then k+1;
- If a[i]>0 then k:=k+a[i];
- If a[i]>0 then k:=k+1;
- If a[i]>0 then k+a[i];
Вопрос 13
В записи D[4]=3.5, D обозначает…
Варианты ответов
- имя ячейки
- имя массива
- обозначение типа
- размерность массива
Вопрос 14
В записи А[10]=3, число 10 обозначает…
Варианты ответов
- индекс элемента массива
- имя массива
- значение элемента массива
- размерность массива
Вопрос 15
Какие значения примут элементы массива A[3] и A[4] после выполнения последовательности операторов
A[3] := 5;
A[4] := 6;
A[3] := A[4];
A[4] := A[3];
Варианты ответов
- A[3] = 6; A[4] = 6
- A[3] = 5; A[4] = 6
- A[3] = 6; A[4] = 5
- A[3] = 5; A[4] = 5


