Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  Язык программированию Pascal

Язык программированию Pascal

Avatar
15.05.2020. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
тест содержит 6 заданий с кратким ответом. Ответом является целое число. Время выполнения теста 30 мин. Система оценивания 5 бальная.

Список вопросов теста

Вопрос 1

Запишите число, которое будет напечатано в результате выполнения следующей программы

var n, s: integer;
begin
n := 1;
s := 0;
while n <= 300 do begin
s := s + 30;
n := n * 5
end;
write(s)
end.

Вопрос 2

Процедура F(n), где n – натуральное число, задана следующим образом:

procedure F(n: integer);
begin
if n < 3 then
write('*')
else begin
F(n-1);
F(n-2);
F(n-2)
end;
end;

Сколько звездочек напечатает эта процедура при вызове F(6)?

Вопрос 3

Исполнитель Редактор получает на вход строку цифр и преобразовывает её.Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.

1. заменить (v, w)
2. нашлось (v)

Первая команда заменяет в строке первое слева вхождение цепочки v на
цепочку w, вторая проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь».
Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 156 идущих подряд цифр 5? В ответе запишите полученную строку.

НАЧАЛО
ПОКА нашлось (333) ИЛИ нашлось (555)
  ЕСЛИ нашлось (555)
    ТО заменить (555, 3)
    ИНАЧЕ заменить (333, 5)
  КОНЕЦ ЕСЛИ
КОНЕЦ ПОКА
КОНЕЦ
Вопрос 4

В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 27. Чему будет равен элемент массива A[27] после выполнения данной программы?

n:=27;
A[1]:=3;
for i:= 2 to n do begin
A[i] := 3*A[i–1] mod 10;
end;

Вопрос 5

Сколько существует таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 12.

var x, a, b: integer;
begin
readln(x);
a:=0; b:=0;
while x > 0 do begin
a:= a + 1;
b:= b + (x mod 10);
x:= x div 10;
end;
writeln(a); write(b);
end.

Вопрос 6

Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера:

1. Прибавить 1
2. Умножить на 2

Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 2 результатом является число 33 и при этом траектория вычислений содержит число 16 и не содержит числа 30?

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт