Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Язык программирования Python

Язык программирования Python

Avatar
17.03.2025. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Вариант 1 проверка знаний по темам: "Оператор присваивания", "Сложные условия", "Программы с циклами ", "Обработка массивов"

Список вопросов теста

Вопрос 1

Определите значение переменной a после выполнения алгоритма:

  a = 6
  b = 3
  b = a // 2 * b
  a = 3 * a + 2 * b

В ответе укажите одно целое число – значение переменной a.

Вопрос 2

Определите значение переменной b после выполнения данного алгоритма:

  a = 6
  b = 6
  a = b * 4
  b = a * 4

В ответе укажите одно целое число – значение переменной b.

Вопрос 3

Ниже приведена программа, написанная на языке программирования Python.

x = int(input())
y = int(input())
if x > 2 and y > 2:
    print(’ДА’)
else:
    print(’НЕТ’)

Было проведено 9 запусков программы, при которых в качестве значений переменных x и y вводились следующие пары чисел:

(6, 8); (3, 5); (–7, 2); (7, 7); (9, 8);

(–1, 3); (–4, 5); (6, 9); (2, –1).

Сколько было запусков, при которых программа напечатала ’НЕТ’?

Вопрос 4

Дана программа:

x = int(input())
y = int(input())
if x < 25 and y <= 20:
      print("ДА")
else:
      print("НЕТ")

Было проведено 10 запусков этой программы, при которых в качестве значений переменных x и y вводились следующие пары чисел:

  (15, 25); (10, 15); (20, 20); (25, 10); (10, 30); 
(25, 20); (20, 30); (15, 20); (20, 15); (30, 10)

Сколько было запусков, при которых программа напечатала «ДА»?

Вопрос 5

Дана программа:

s = int(input())
t = int(input())
A = int(input())
if s < A and t < 5:
      print("ДА")
else:
      print("НЕТ")

Было проведено 9 запусков этой программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

  (10, 15); (-6, -3); (11, 5); (8, -8); (4, -11); 
(12, 5), (-11, -8), (15, 0), (10, 7) 

Сколько существует целых значений параметра А, при котором для указанных входных данных программа напечатает «НЕТ» 8 раз.

Вопрос 6

Определите, что будет напечатано в результате работы следующей программы.

  s = 5
  for k in range(1, 8):
    s = s + 11
  print( s )
Вопрос 7

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[0] заданий сделал первый ученик, Dat[1] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.

  Dat = [7, 9, 10, 5, 6, 7, 9, 8, 6, 7]
  m = 0
  for k in range(10):
    if Dat[k] < 8:
      m = m + 1
  print( m )
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт