Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Язык программирования Python

Язык программирования Python

Avatar
17.03.2025. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Вариант 2 проверка знаний по темам: "Оператор присваивания", "Сложные условия", "Программы с циклами ", "Обработка массивов"

Список вопросов теста

Вопрос 1

Определите значение переменной a после выполнения алгоритма:

a = 8
b = 3
b = a // 2 * b
a = 3 * a + 2 * b
В ответе укажите одно целое число – значение переменной a.
Вопрос 2

Определите значение переменной а после выполнения данного алгоритма:

  b = 8
  a = 9
  b = b + a * 2
  a = 29 - a 

В ответе укажите одно целое число – значение переменной b.

Вопрос 3

Ниже приведена программа, записанная на языке программирования python.

x = int(input())
y = int(input())
if x >= 10 or y > 5:
    print(’True’)
else:
    print(’False’)

Было проведено 8   запусков программы, при которых в качестве значений переменных x   и y   вводились следующие пары чисел:

(10,5); (− 7,− 2); (7,− 7); (9,1); (− 1,3); (− 4,5); (11,0); (2,6).

Сколько было запусков, при которых программа напечатала True?

Вопрос 4

Дана программа:

x = int(input())
y = int(input())
if y > 30 or x < 20:
     print("ДА")
else:
     print("НЕТ")

Было проведено 10 запусков этой программы, при которых в качестве значений переменных x и y вводились следующие пары чисел:

  (35, 25); (20, 35); (30, 20); (25, 10); (40, 30); 
(15, 25); (20, 30); (35, 15); (35, 20); (30, 10) 
Сколько было запусков, при которых программа напечатала «ДА»?
Вопрос 5

Дана программа:

s = int(input())
t = int(input())
A = int(input())
if s < A and t < 5:
     print("ДА")
else:
      print("НЕТ")

Было проведено 9 запусков этой программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

  (10, 15); (-6, -3); (11, 5); (8, -8); (4, -11); 
(12, 5), (-11, -8), (15, 0), (10, 7) 

Сколько существует целых значений параметра А, при котором для указанных входных данных программа напечатает «НЕТ» 7 раз.

Вопрос 6

Определите, что будет напечатано в результате работы следующей программы.

  s = 11
  for k in range(1, 10):
    s = s + 12
  print( s )
Вопрос 7

В таблице Dat хранятся данные ежедневных измерений количества осадков за неделю в миллиметрах (Dat[0] – данные за понедельник, Dat[1] – за вторник и т.д.). Определите, что будет напечатано в результате выполнения
следующего алгоритма.

  Dat = [14, 10, 0, 15, 0, 15, 10]
  day = 0
  for k in range(7):
    if Dat[k] == 0:
      day = k
  print( day )
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт