Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Язык программирования Python

Язык программирования Python

Avatar
17.03.2025. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Вариант 3 проверка знаний по темам: "Оператор присваивания", "Сложные условия", "Программы с циклами ", "Обработка массивов"

Список вопросов теста

Вопрос 1

Определите значение переменной а после выполнения данного алгоритма:

  a = 6
  b = 2
  b = a + 2 * b
  a = a * 5 // b

В ответе укажите одно целое число – значение переменной а.

Вопрос 2

Определите значение переменной b после выполнения данного алгоритма:

  a = 2
  b = 4
  a = b * 4
  b = a * 4

В ответе укажите одно целое число – значение переменной b.

Вопрос 3

Ниже приведена программа, написанная на языке программирования Python.

x = int(input())  
y = int(input())  
if x >= y:  
    print(’ДА’)  
else:  
    print(’НЕТ’)

Было проведено 9 запусков программы, при которых в качестве значений переменных x и y вводились следующие пары чисел:

(6, 8); (3, 5); (–7, 2); (7, 7); (9, 8);

(–1, 3); (–4, 5); (6, 9); (2, –1).

Сколько было запусков, при которых программа напечатала ’ДА’?

Вопрос 4

Дана программа:

x = int(input())
y = int(input())
if y >= 150 and x <= 200:
      print("ДА")
else:
       print("НЕТ")

Было проведено 10 запусков этой программы, при которых в качестве значений переменных x и y вводились следующие пары чисел:

(240, 180); (150, 200); (210, 200); (130, 150); (190, 140); 
(210, 170); (180, 210); (170, 90); (210, 210); (200, 150)

Сколько было запусков, при которых программа напечатала «НЕТ»?

Вопрос 5

Дана программа:

s = int(input())
t = int(input())
A = int(input())
if s < A and t < 5:
      print("ДА")
else:
      print("НЕТ")

Было проведено 9 запусков этой программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

  (10, 15); (-6, -3); (11, 5); (8, -8); (4, -11);  (12, 5), 
(-11, -8), (15, 0), (10, 7) 

Сколько существует целых значений параметра А, при котором для указанных входных данных программа напечатает «НЕТ» 6 раз.

Вопрос 6

Определите, что будет напечатано в результате работы следующей программы.

  s = 8
  for k in range(1,12):
    s = s + 12
  print( s )
Вопрос 7

В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[0] – данные за первый день, Dat[1] – за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.

  Dat = [12, 15, 17, 15, 14, 12, 10, 13, 14, 15]
  m = 20
  for k in range(10):
    if Dat[k] < m:
      m = Dat[k]
  print( m )
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт