Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  Элементы языка Паскаль и типы данных. Операции и выражения

Элементы языка Паскаль и типы данных. Операции и выражения

Avatar
25.01.2023. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Проверка усвоенных знаний по теме "Элементы языка Паскаль и типы данных. Операции и выражения"

Список вопросов теста

Вопрос 1

Определите значение переменной a после выполнения алгоритма:

  a := 16;
  b := 2;
  b := a * b - 8;
  a := b + b / 4 ;
Варианты ответов
  • 8
  • 30
  • 32
  • 12
Вопрос 2

Чему будет равна переменная c после выполнения этой программы:

  a := 20;
  b := 3;
  b := a div b + а - 10 ;
  c := a mod b + a;
Варианты ответов
  • 21
  • 24
  • 22
  • 15
Вопрос 3

Укажите верные высказывания:

 

Варианты ответов
  • Команды в программе отделяются друг от друга точкой с запятой «;»
  • Имя программы может состоять из любого количества любых символов
  • Нельзя присваивать программам имена зарезервированных языком программирования слов (begin, end, program)
Вопрос 4

Укажите допустимые имена величин в языке Паскаль:

Варианты ответов
  • ЖУК2
  • sUmmA
  • _dOm
  • 2ROK
  • ROL2
Вопрос 5

Какие из следующих последовательностей символов можно считать операторами присваивания?

Варианты ответов
  • k:=k+6
  • M1:=n div 3
  • M1+5 :=M
  • c=c-10
  • f:=4f
  • s:=85
Вопрос 6

Какое из перечисленных слов не относится к служебным словам языка программирования Паскаль?

Варианты ответов
  • Begin
  • Or
  • Print
  • Writeln
Вопрос 7

Установите соответствие

1.

-32 768 … 32 768

2.

true и false

3.

Произвольный символ алфавита

4.

Последовательность не более чем из 255 символов 

Варианты ответов
  • char
  • string
  • integer
  • boolean
Вопрос 8

Как можно представить структуру программы на языке Паскаль?

Варианты ответов
  • Program Begin End
  • Program End Begin
  • Begin Program End
  • Program If Then Else End
Вопрос 9

Переменной a присвоено значение 5. Установите соответствие записи оператора вывода и вида выведенного на экран результата:

1.

Write(a)

2.

Write(‘a=’, a)

3.

Write(‘a’)

Варианты ответов
  • 5
  • a
  • a=5
Вопрос 10

С помощью какой команды нельзя присвоить значение переменной a?

Варианты ответов
  • С помощью команды read(a)
  • С помощью команды write(a)
  • С помощью команды присваивания
Вопрос 11

Целочисленным переменным a, b, c надо присвоить соответственно значения 1, 2 и 3. Какой оператор ввода соответствует входному потоку 2 1 3?

Варианты ответов
  • read b, a, c
  • read (a, b, c)
  • readln (a, b, c)
  • read (b, a, c)
Вопрос 12

Что будет выведено на экран после выполнения следующей программы:

begin
writeln (‘Hello, ’);
write (‘World!’)
end.

Варианты ответов
  • ‘Hello, ‘ ’World!’
  • Hello, World!
  • ‘Hello, ‘’World!’
  • Hello,World!
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт