Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Алгоритмы обработки массивов

Алгоритмы обработки массивов

Avatar
12.02.2023. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Язык Python: Алгоритмы обработки массивов 9 класс.

Список вопросов теста

Вопрос 1

Через пробел запишите числа, которые будут в списке
A = [i for i in range (10) if i % 2 == 0]

Вопрос 2

A=[0]*5

Запишите через пробел значения элементов массива, сформированного следующим образом:

for i in range(5):
    if i % 2 == 0: A[i] = i + 10

Вопрос 3

Запишите через пробел значения элементов массива, сформированного следующим образом:

for i in range(5): A[i] = 3

Вопрос 4

A = [2, 13, 1, 14, 6, 15]

Что выведет программа?

A[1] = A[0] + A[5]

print3*A[1]+A[4] )

Вопрос 5

Что выведет программа?

A = [13, 31, 3, 46, 53, 6, 63]
k=0
for i in range(7):
  if A[i] % 10 == 3: k += 1
print(k)

Вопрос 6

A = [2, 13, 1, 14, 6, 15]

Что выведет программа?

for k in range(6):

  A[k] += 2

print2*A[3]+3*A[4] )

Вопрос 7

A= [ 3, 4, -1, 5, 0, 10, -12]

Чему равно значение А[A[3]]?

Вопрос 8

Массив задан следующим образом:

В= [2, 1, 2, 3, 5, 11] .

Найдите значение выражения

В [5] * В [ 4 ] - В [2 ] - В [3] * В [ 1 ]

Вопрос 9

A = [2, 13, 1, 14, 6, 15]

Что выведет программа?

print( A[3] )

Вопрос 10

Что выведет программа?

A = [13, 34, 4, 46, 53, 6, 63]

summa = 0

for x in A:

  if x % 2 != 0:

    summa += x

print ( summa )

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт