Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Алгоритмы и их программирование в Python

Алгоритмы и их программирование в Python

Avatar
05.03.2024. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Линейный, разветвляющийся и циклический алгоритмы и их программирование в Python

Список вопросов теста

Вопрос 1

Назовите тип алгоритма

Варианты ответов
  • Разветвляющийся
  • Линейный
  • Циклический
Вопрос 2

Результат выполнения этого алгоритма при введённых а = 5 и b = 2 будет

Варианты ответов
  • S = 10 P = 20
  • S = 10 P = 14
  • P = 14 S = 10
Вопрос 3

Результат выполнения этого алгоритма при введённых z = 48  будет

Варианты ответов
  • 8
  • 4
  • 57
  • 16
Вопрос 4

Назовите тип алгоритма

Варианты ответов
  • линейный
  • разветвляющийся
  • циклический
Вопрос 5

Назовите тип алгоритма

 

Варианты ответов
  • циклический
  • линейный
  • разветвляющийся
Вопрос 6

Результатом выполнения этого алгоритма будет

Варианты ответов
  • 15
  • 6
  • 5
Вопрос 7

Что хранит в себе переменная?

Варианты ответов
  • значение
  • имя
  • тип
Вопрос 8

Установите соответствие между названиеми типов данных и их обозначением в Python

1.

int

2.

float

3.

str

4.

bool

Варианты ответов
  • вещественный
  • строковый
  • целочисленный
  • логический
Вопрос 9

Укажите оператор ввода:

Варианты ответов
  • print()
  • input()
  • random()
  • int()
Вопрос 10

Укажите оператор вывода:

Варианты ответов
  • print()
  • input()
  • random()
  • int()
Вопрос 11

Какой оператор здесь используется?

 if   n < 100:

       b = n + a

Варианты ответов
  • Условный оператор
  • Оператор присваивания
  • Оператор сложения
Вопрос 12

Для использования в программе случайных чисел необходимо добавить 

Варианты ответов
  • from math import randint
  • from random import randint
  • randint
Вопрос 13

а = 345

Что выведет команда print(a//100)

Варианты ответов
  • 3
  • 34
  • 3.45
Вопрос 14

а = 345

Что выведет команда print(a%100)

Варианты ответов
  • 5
  • 45
  • 0.5
Вопрос 15

В какой строке правильно записан ввод числа с клавиатуры?

Варианты ответов
  • a = int(input()
  • c = int(input())
  • b = input()
Вопрос 16

В какой строке допущена синтаксическая ошибка?

  1.  a = int(input())
  2.  if a>0
  3.         print(a)
  4.  else:
  5.        print("нет")

 

Варианты ответов
  • 3
  • 2
  • 4
  • 5
Вопрос 17

Какой алгоритм реализует данная программа

a = int(input())

b = int(input())

c = int(input())

s = a+b+c

print(s)

    1.  
Варианты ответов
  • циклический
  • линейный
  • разветвляющийся
Вопрос 18

Чему равно значение переменной k в результате работы программы

             k = 5

             for x  in range(10, 1, 3):

                       k += 1

          

 

Варианты ответов
  • 9
  • 5
  • 4
  • 8
Вопрос 19

Какой результат будет при а = 0

             if a > 0:

        s = a**2 + 1

else:

        s = a*2 + 3

Варианты ответов
  • 1
  • ничего
  • 3
Вопрос 20

Чему равно значение переменной k в результате работы программы

        k = 2

        for x  in range(2, 10, 2):

                 k += 1

     

Варианты ответов
  • 4
  • 5
  • 6
Вопрос 21

Какие значения будут напечатаны в ходе выполнения программы:

i = 0 
while i < 5:
    print(i) 
    i += 1

Варианты ответов
  • 4
  • 0 1 2 3 4
  • 1 2 3 4 5
  • 0 1 2 3 4 5
Вопрос 22

Чему равно значение переменной а после выполнения программы при следующих введённых значениях X:  4   7   2    3    7    11

a = 100000

x = int(input("Введи число "))
while x != 0:

     if   x < a:

            a = x
     x = int(input("Введи число ")) 

 

Варианты ответов
  • 2
  • 11
  • 4
  • 0
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт