Задание в тетради
1. Чему будет равно значение переменной y при n=10 после выполнения программы:
program qwe;
var x, y, n: integer;
Begin
writeln('Введи целое n='); 3 балла
readln(n);
y:=1;
for x:=1 to n do y:=2*у+3;
writeln(n,'=',y);
end.
2. Определить значение целочисленной переменной с после выполнения следующего фрагмента блок-схемы:

3. Вычислить значения выражения:
- 3*7 div 2 mod 7/3 – trunс (0.89)
- 10 + trunc(3 + 11 / 3) - round ((10 + 3) / 3) 3 балла
- 10 – round (3 + 11 / 3) - trunc ((10 + 3) / 3)
4. Запишите на языке программирования следующие выражения: - смотри документ
5. Переведите из линейной формы записи в обычную:
|
|
2 балла |
6. Чему будет равен результат вычисления фрагмента программы:
readln(a,b,c);
d:=(a mod 4 +2 * b div 3 -4) mod c + 1; 1 балл
writeln('d=',d);
при a=11; b=14; c=3
7. Нарисуй блок-схему к предыдущей программе. 4 балла
Задание на компьютере
8. Напишите программу, которая по введенному номеру месяца високосного или невисокосного года, выводит количество дней в месяце.
9. Напишите программу, которая по введенному числу из промежутка 0..24, определяет время суток.
Критерий оценки
Задание в тетради: 18-16 баллов – «5», 15-13 баллов – «4», 12-10 баллов – «3»
Задание на компьютере: выполнение одной задачи – «4», выполнение двух задач – «5».



Самостоятельная работа в Паскале (83.67 КB)

