Задание №1
Изучить теоретический материал по теме лабораторной работы №1.
Создать программу, автоматизирующую процесс решение задачи в соответствии с вариантом.
Составить отчет о проделанной работе (в отчет включить условие задачи, блок-схема, программа на Pascal, результаты выполнения программы).
Варианты заданий:
Нефтебаза отпустила за два дня S л. бензина. Во второй день база отпустила на V л. больше. Сколько литров бензина база отпустила отдельно за каждый день?


st:= (summa - raz) / 2.0;
day1:= st;
day2:= st + raz;
uses crt;
var summa,raz,st,day1,day2:real;
b
egin;
clrscr;
write('Сколько литров бензина отпустила нефтебаза за 2 дня');
readln(summa);
writeln('Введите на сколько отпущенное кол-во бензина
одного дня больше чем другого');
readln(raz);
st:= (summa - raz) / 2.0;
day1:= st;
day2:= st + raz;
writeln('первый день-',day1:7:2,'л.');
writeln('второй день-',day2:7:2,'л.');
end.

Задание №2
Изучить теоретический материал по теме лабораторной работы №2.
Создать программу, автоматизирующую процесс решение задачи в соответствии с вариантом.
Составить отчет о проделанной работе (в отчет включить условие задачи, блок-схема, программа на Pascal, результаты выполнения программы).
Варианты заданий:
Таблица 1. Задания
| № | выражение | х | у |
| 1 |
| 1 | 1,47 |



y:=(2*cos(x-p/6))/(1/2+sqr(sin(x)))

program primer2;
var x,y: real;
p:=3.14;
begin
writeln('Введите x');
read (x);
y:=(2*cos(x-p/6))/(1/2+sqr(sin(x)));
writeln('Ответ=', y:3:3);
end.

Задание №3
Изучить теоретический материал по теме лабораторной работы №4.
Создать программу, автоматизирующую процесс решение задачи в соответствии с вариантом.
Составить отчет о проделанной работе (в отчет включить условие задачи, блок-схема, программа на Pascal, результаты выполнения программы).
Варианты заданий:
Таблица 2. Задания
| № | выражение |
| 1 |
|

var
x: integer;
y: real;
begin
write ('x = ');
readln (x);
if x 3 then
y := sqr(x)-3*x+9
else
if x 3 then
y :=(1/(sqr(x)*x+6));
writeln ('y = ', y);
readln
end.
Задание №4
Порядок выполнения индивидуальной работы
Изучить теоретический материал по теме лабораторной работы №5.
Создать программу, автоматизирующую процесс решение задачи в соответствии с вариантом.
Составить отчет о проделанной работе (в отчет включить условие задачи, блок-схема, программа на Pascal, результаты выполнения программы).
Варианты заданий:
Написать программу, которая по вводимому числу от 1 до 5 (номеру курса) выдает соответствующее сообщение «Привет, k-курсник». Например, если k=1 «Привет, первокурсник»; при k=4 «Привет, четверокурсник».
program primer4;
uses crt;
var kyrs: integer;
begin
writeln ('Vvedite nomer kyrsa');
read(kyrs);
if kyrs=1 then writeln('Privet pervokyrsnik');
if kyrs=2 then writeln('Privet vtorokyrsnik');
if kyrs=3 then writeln('Privet tretekyrsnik');
if kyrs=4 then writeln('Privet chetverokyrsnik');
if kyrs=5 then writeln('Privet pyatikyrsnik');
end.
Задание №5
Порядок выполнения индивидуальной работы
Изучить теоретический материал по теме лабораторной работы №6.
Создать программу, автоматизирующую процесс решение задачи в соответствии с вариантом.
Составить отчет о проделанной работе (в отчет включить условие задачи, блок-схема, программа на Pascal, результаты выполнения программы).
Варианты заданий 1:
Использовать циклы с пред- и пост условием.
Билет называется «счастливым», если в его номере сумма первых трех цифр равно сумме последних трех. Написать программу, подсчитывающую количество тех «счастливых» билетов, у которых сумма трех цифр равна 13.
program SpecialHappyTickets;
var
i, j, k, l, m, n, s: integer;
begin
s := 0;
for i := 0 to 9 do
for j := 0 to 9 do
for k := 0 to 9 do
for l := 0 to 9 do
for m := 0 to 9 do
for n := 0 to 9 do
if (i + j + k) = (l + m + n) then
if i + j + k = 13 then s := s + 1;
Writeln(s)
end.
Задание №6
Порядок выполнения индивидуальной работы
Изучить теоретический материал по теме лабораторной работы №7.
Создать программу, автоматизирующую процесс решение задачи в соответствии с вариантом.
Составить отчет о проделанной работе (в отчет включить условие задачи, блок-схема, программа на Pascal, результаты выполнения программы).
Варианты заданий:
Дан одномерный массив (заполняется пользователем), написать программу, которая решает поставленную задачу в соответствии с индивидуальным вариантом.
Количество четных чисел.
Program primer6;
Var a: array[1..100] of integer;
i, n, k: integer;
Begin
Write ('n='); Readln (n);
For i:=1 to n do
begin
Write('a[',i,'’]='); readln (a[i]);
if a[i] mod 2=0 then k:=k+1;
end;
Writeln('количество четных элементов: ', k);
end.


Решения (подробное) контрольных работ на TPascal (626.5 KB)

