Меню
Разработки
Разработки  /  Информатика  /  Презентации  /  9 класс  /  Реализация циклического алгоритма на Паскале 9 класс

Реализация циклического алгоритма на Паскале 9 класс

Цикл – это многократно повторяющиеся фрагменты программ.

Алгоритм циклической структуры – это алгоритм, содержащий циклы.

21.07.2019

Содержимое разработки

Реализация циклического алгоритма на Паскале

Реализация циклического алгоритма на Паскале

Что такое разветвляющийся алгоритм и его реализация на языке Паскаль (Условный оператор)? «Тайм Раунд Робин»

Что такое разветвляющийся алгоритм и его реализация на языке Паскаль

(Условный оператор)?

«Тайм Раунд Робин»

Цикл  – это многократно повторяющиеся фрагменты программ.  Алгоритм циклической структуры  – это алгоритм, содержащий циклы.    В ТР существует три оператора цикла: цикл с предусловием; цикл с постусловием; цикл с параметром.

Цикл  – это многократно повторяющиеся фрагменты программ. 

Алгоритм циклической структуры  – это алгоритм, содержащий циклы.  В ТР существует три оператора цикла:

  • цикл с предусловием;
  • цикл с постусловием;
  • цикл с параметром.
Оператор цикла с предусловием в Паскале Формат записи:  While  (выражение логич. типа) do  (тело цикла);  где:   While – пока не;  do  – выполнить;

Оператор цикла с предусловием в Паскале

Формат записи:

While  (выражение логич. типа) do  (тело цикла);

где:  While – пока не; do  – выполнить;

Пример: Найти функцию у = ах 2  – b для х изменяющегося от –7 до +12 с шагом +1): x:= -7; while x begin y:= a*x*x – b; writeln (x, y); x:= x+1; end;

Пример: Найти функцию у = ах 2  – b для х изменяющегося от –7 до +12 с шагом +1):

x:= -7;

while x

begin

y:= a*x*x – b;

writeln (x, y);

x:= x+1;

end;

Оператор цикла с постусловием в языке Паскаль Формат записи:  Repeat (тело цикла)  Until   (выраж. логич. типа);  где:   Repeat – повторять;  Until  – пока не;

Оператор цикла с постусловием в языке Паскаль

Формат записи:

Repeat (тело цикла)  Until   (выраж. логич. типа);

где:  Repeat – повторять; Until  – пока не;

12; end. " width="640"

Пример: Найти функцию у = ах 2  – b для х изменяющегося от –7 до +12 с шагом +1):

x:= -7;

repeat

y:= a*x*x – b;

writeln (x, y);

x:= x+1;

until x 12;

end.

Оператор цикла с параметром в языке Паскаль Формат записи:  1.   For P:=(начальное значение параметра) to (конечное значение параметра) do (тело цикла);  2.   For P:= (конечное значение параметра) downto (начальное значение параметра) do (тело цикла);   где:   For – для;  to  – до;  downto – уменьшая до  do     –  выполнить;

Оператор цикла с параметром в языке Паскаль

Формат записи:

1.   For P:=(начальное значение параметра) to (конечное значение параметра) do (тело цикла); 2.   For P:= (конечное значение параметра) downto (начальное значение параметра) do (тело цикла);

где:  For – для; to  – до; downto – уменьшая до do     –  выполнить;

Пример: Найти функцию у = ах 2  – b для х изменяющегося от –7 до +12 с шагом +1): For P:= -7 to 12 do y:= a*x*x – b;

Пример: Найти функцию у = ах 2  – b для х изменяющегося от –7 до +12 с шагом +1):

For P:= -7 to 12 do y:= a*x*x – b;

Найти функцию y = 5x – 2 на отрезке [1; 20] с шагом b=2. 2. Написать программу нахождения функции у=х 2 +2. Диапазон изменения аргумента от – 4 до 4 с шагом +1.  «Релли Коуч»
  • Найти функцию y = 5x – 2 на отрезке [1; 20] с шагом b=2.

2. Написать программу нахождения функции у=х 2 +2. Диапазон изменения аргумента от – 4 до 4 с шагом +1.

«Релли Коуч»

20; end; end. С предусловием x:= -4; С параметром For P:= -4 to 4 do y:= x*x + 2; while x begin y:= х*x + 2; writeln (x, y); x:= x+1; end; «Релли Коуч» " width="640"

С предусловием

С постусловием

x:= 1;

x:= 1;

while x

repeat

begin

y:= 5*x – 2;

y:= 5*x – 2;

writeln (x, y);

writeln (x, y);

x:= x+2;

x:= x+2;

until x 20;

end;

end.

С предусловием

x:= -4;

С параметром

For P:= -4 to 4 do y:= x*x + 2;

while x

begin

y:= х*x + 2;

writeln (x, y);

x:= x+1;

end;

«Релли Коуч»

Практическая работа в Паскале Задание:  Вычислить  у =  4 х 2  +  3 х ;  х  меняется от –3 до 6 с шагом 0.5.

Практическая работа в Паскале

Задание:

Вычислить  у =  4 х 2  +  3 х

х  меняется от –3 до 6 с шагом 0.5.

Домашнее задание Найти функцию y = 4x-5 на отрезке [1; 30] с шагом h = 3.  2. Найти функцию y = 5x² - 2x +1 на отрезке [-5; 5] с шагом h = 2.

Домашнее задание

  • Найти функцию y = 4x-5 на отрезке [1; 30] с шагом h = 3.

2. Найти функцию y = 5x² - 2x +1 на отрезке [-5; 5] с шагом h = 2.

-75%
Курсы повышения квалификации

Специфика преподавания дисциплины «Информационные технологии» в условиях реализации ФГОС СПО по ТОП-50

Продолжительность 72 часа
Документ: Удостоверение о повышении квалификации
4000 руб.
1000 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Реализация циклического алгоритма на Паскале 9 класс (150.2 KB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт

© 2008-2024, ООО «Мультиурок», ИНН 6732109381, ОГРН 1156733012732

Учителю!
Огромная база учебных материалов на каждый урок с возможностью удаленного управления
Тесты, видеоуроки, электронные тетради