Меню
Разработки
Разработки  /  Информатика  /  Уроки  /  10 класс  /  Решение задач линейного программирования на языке Паскаль

Решение задач линейного программирования на языке Паскаль

Цель урока - сформировать навыки программирования на языке Паскаль. Разработка содержит задания для закрепления знаний по структуре программы, основным операторам линейного программирования, отработки навыков написания программ обработки данных целого типа.
02.10.2012

Описание разработки

Цель урока - сформировать навыки программирования на языке Паскаль. Разработка содержит задания для закрепления знаний по структуре программы, основным операторам линейного программирования, отработки навыков написания программ обработки данных целого типа.

План-конспект урока по информатике Решение задач линейного программирования на языке Паскаль

 

Содержимое разработки

Глинкина Ирина Викторовна, учитель информатики МБОУ «Гимназия№4» г.о.Дзержинский Московская область





ПЛАН-КОНСПЕКТ УРОКА

ПО ИНФОРМАТИКЕ В 10 КЛАССЕ

УЧИТЕЛЬ ГЛИНКИНА И.В.



ТЕМА: «РЕШЕНИЕ ЗАДАЧ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ НА ЯЗЫКЕ ПАСКАЛЬ»



ЦЕЛЬ:

СФОРМИРОВАТЬ НАВЫКИ ПРОГРАММИРОВАНИЯ НА ЯЗЫКЕ ПАСКАЛЬ


ЗАДАЧИ:

- ОТРАБОТАТЬ НАВЫКИ НАПИСАНИЯ ПРОГРАММ ОБРАБОТКИ ДАННЫХ ЦЕЛОГО ТИПА

- ЗАКРЕПИТЬ ЗНАНИЯ О СТРУКТУРЕ ПРОГРАММЫ И ОСНОВНЫМ ОПЕРАТОРАМ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ



План:


  1. Повторение материала предыдущих занятий. – 8 мин.

  2. Самостоятельная работа. - 10 мин.

  3. Новый материал. – 5 мин.

  4. Закрепление – практическая работа – 15 мин.

  5. Подведение итогов урока – 2 мин.


Ход урока:


  1. Орг. момент.


  1. Повторение:


Учитель задает вопросы:


1). Из каких разделов состоит программа на языке Паскаль?

(Раздел заголовка, раздел описаний, раздел операторов).


2). С какого служебного слова начинается программа?

(Program)


3). Как описываются переменные?

(Var список переменных: тип переменных).


4). С чего начинается основная программа?

(Begin)


5). Как записывается оператор вывода?

(Writeln (‘текст’, список переменных))


6). Как записывается оператор ввода?

(Readln(список переменных))


7). Как записывается оператор присваивания?

(имя переменной := арифм. выражение)


8). Чем заканчивается программа?

(End.)


9). Какие вы знаете операции над величинами целого типа?

(сложение +, вычитание -, умножение *, получение целой части от деления div, получение остатка от деления mod)


10). Каков порядок выполнения этих операций?


На доске записаны примеры, посчитайте устно, чему будут равны значения переменных a и b:


1) a := 15 div (16 mod 7); (7)

b := 34 mod a*5 – 29 mod 5*2. (22)


2) a := 4*5 div 3 mod 2; (0)

b:= 4*5 div (3 mod 2). (20)


Самостоятельная работа на листочках:

  1. Найдите ошибки в программе и исправьте их;

  2. Напишите, что делает эта программа;

  3. Отметьте разделы программы.

  4. Напишите программу.


1 вариант:

1) Programm My 1;

Var x, c1, c2 – Integer;

Begin;

Writeln (“Введите 2-значное число”);

Readln (x);

c1 = x mod 10

c2 := x div 10;

s : c1 + c2;

Writeln (‘ответ: ‘, s);

Readln;

End


2) Найти сумму крайних цифр четырехзначного числа.


2 вариант:

1) Prodram 12;

Var x, c1, c2 : Integer

Begin:

Writeln (‘Введите 2-значное число’);

Readeln (x);

c1 := x mod 10;

c2 = x div 10;

s = c1  c2;

Writeln (‘ответ: , s’);

Readln;

End.


2) Найти сумму средних цифр четырехзначного числа.


  1. Новый материал.

Сегодня мы научимся получать новые числа путем перестановки цифр исходного числа.

Дано: х = .

Получить: y =.

Число х можно представить в виде суммы разрядных слагаемых:

х = с3*100 + с2*10 + с1, тогда y = с1*100 + с2* 10 +с3.


Получим следующую программу:

Program My23;

Var x, c1, c2, c3, y : integer;

Begin

Writeln (‘Введите 3-значное число’);

Readln (x);

c1 := x mod 10;

c2 := (x div 10) mod 10;

c3 := x div 100;

y := c1*100 +c2*10 +c3;

Writeln (‘Новое число – ‘, y);

Readln;

End.

Какие у вас вопросы?

Сколько всего можно получить различных чисел? (6).


  1. Закрепление.

Практическая работа за компьютером

Задания:

  1. Используя эту программу, получите все возможные числа.

  2. Из 4-значного числа получить новое путем перестановки цифр сотен и десятков и тысяч и единиц.

  3. Дополнительно: Из 5-значного числа получить новое, переставив местами его крайние и средние цифры.

-80%
Курсы дополнительного образования

Создание динамических веб-страниц с помощью PHP и MySQL

Продолжительность 72 часа
Документ: Cвидетельство о прохождении курса
4000 руб.
800 руб.
Подробнее
Сохранить у себя:
Решение задач линейного программирования на языке Паскаль (0.04 MB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт